Downloading Files or printing to a file on PC - Failed: insufficient permissions

Description of the issue:

I receive the error message “Failed - Insufficient permissions” when trying to download attachments in my email, or if I click the “print” in the menu to print something off the internet, or to save it as a PDF. It doesn’t matter what website, or whether it is an article or just to print (as PDF or download), I get this error msg whenever I want to download, save or print to file.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
I click the download arrow next to the attachment (in my email app) it starts to download, but then I get the above error message & it does not download.
Or I find something I want to download on a webpage whether to download an article, or to use the “print” feature in the menu. I receive the same error message when it attempts to download to my PC

Actual Result (gifs and screenshots are welcome!):
I receive the error message “Failed - Insufficient Permissions”

Expected result:
I would hope to be able to download attachments from email, or things I print or save from the Internet to my PC desktop

Reproduces how often:
This happens every time

Operating System and Brave Version(See the About Brave page in the main menu):
System Info my PC

“Brave” Version 1.42.88 Chromium: 104.0.5112.81 (Official Build) (64-bit)

Additional Information:
At first it would only let me download to my “download” folder even though I picked the choice to let me choose what file. But now for about 2 weeks it has not been allowing me to save anything to my PC. I looked up the “Help” info on this & nothing applies & there is no choice for this: To fix the error:

  • Instead of clicking the file to download, right-click the link and select Save link as
    Also as I said it won’t let me download attachments sent to me by websites I am a member of, such as websites that send me a receipt for something purchased.

Thanks for any support or help you can give me!

1 Like

@jan4him,
Can you please update to the latest build. — v1.42.97 at. the time of writing this — and tell me if the issue persists?

If it does, can you tell me if you have any extensions installed? Additionally, where do you have downloads set to go by default (Settings --> Additional --> Downloads)
?

Ok, I did update to the latest build. This is where I have it designated to download:
Location

C:\Users\Janb4him\Downloads
I also have the “Ask where to save each file before downloading” chosen

The problem still persists, thanks for getting back to me

Hey! I just encountered a similar problem and solved it with inspiration from another thread. I closed brave, and went into task manager and ended all brave-related tasks. (BraveSoftware Update and BraveSoftware Update 32bit)

Hi thanks for the info, but I tried it & it didn’t work for me. Exactly which tab did you use when you went into the task manager?

Have you tried changing the download location? I’m wondering if setting it to Desktop or something for a test might make a difference.

Is the email part of a website you’re signed into in Brave or is it an external program/app?

Does this happen anywhere else or just in your email?

Under processes, i just scrolled until i found processes that started with “b” and then i removed deleted all brave processes (of course, after ending task for brave.exe as well)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.