English-language bank website version no longer appears in Brave but works in other browsers

NOTE: Any “one-liner” or topics requesting support or reporting bugs that do not make an effort to include as much of this information as possible will not be responded to. Repeatedly posting as such is grounds for banning._
Please try to adhere to this template when reporting bugs. If you think you don’t need to fill out every section in the template fill out as much of it as you can and please be as descriptive as possible when posting.
<---------Delete this line and everything above before posting---------->

Description of the issue:
I live and bank in the Republic of Georgia (not the state of Georgia). The website of the Bank of Georgia (my bank) has a toggle between English and Georgian language versions, which worked fine on Brave until very recently. They still work fine on other browsers than Brave. Now when I click “ENG” I still get Georgian language, just as when I click “GEO”.English-language homepage for Bank of Georgia

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Actual Result (gifs and screenshots are welcome!):

Expected result:
Shown in Chrome browser:

Reproduces how often:
Every time in the last several days. Worked fine earlier.
Operating System and Brave Version(See the About Brave page in the main menu):
MacOS version 12.5.1 (21G83)
Brave Version 1.42.97 Chromium: 104.0.5112.102 (Official Build) (x86_64)

**Additional Information:**Simultaneous to the above, my bank’s private banking website called Solo is experiencing the identical problem, but only on Brave, and only recently.Solo English-language homepage
I spoke to my private banker about this. The bank has no clue about this problem. I use these websites a lot, and I don’t want to leave Brave as my default browser.

Try turning off shields and retrying.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.