Enable javascript on local files

Hey there. I like to be as private as I can while I’m browsing the internet so I’ve got my javascript turned off by default. Every time I visit a site that doesn’t appear to be working without scripts, I consider switching it on and continue browsing the internet uninterrupted. However, when I try to open local files, Brave Shields block all scripts without giving me the option to turn them back on (grey logo). Is there a reason for this? I’m using version 1.25.70 and Chromium 91.0.4472.77 right now. At the moment I’m relying on other browsers to open my local files.

A solution for this would be useful for me as well. Surely there are more than two people who want to enable javascript for local files.

1 Like

Hey @Mr.F @CamSpotterNL !

Are you referring to local .html files and such? (Like a development website)

Porridge

From time to time I save a web page (Save page as… Webpage, complete) for future reference. If the page uses javascript, when I open it later I cannot enable javascript. The message I get is “You’re viewing a local or shared file.”

1 Like

First of all, JavaScript is widely used in frontend development. This language, along with HTML and CSS, is part of the essential front-end toolkit.

Someone please help. This is absolutely essential.
Many developers test their pages in a static environment.
We use Javascript BECAUSE IT WORKS IN A STATIC ENVIRONMENT.
It is essential that scripts run at the file:// level.
I am beyond disappointed that Brave cannot do this.

Please allow a setting at least to enable this.

What are you guys thinking?!?!?! This is insanity. Turn this on. I need to get work done.