Enable 3D mode in Google Maps without turning shields off?

windows
#1

Description of the issue:
When using Google Maps in Brave, 3D Earth mode is disabled unless you switch to “Shields Down” mode. The only thing Brave is blocking on this page (for me, anyway…) is a device recognition item. If I go to “shields down” mode, 3D Earth Mode works. Is there anyway around this without disabling the recognition blocking? Perhaps the script is not just recognition and is actually a functional script.
(Google’s help note about enabling Hardware Acceleration does not apply here, as it’s already on.)

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Go to https://maps.google.com with brave shields up. Notice that 3D Earth mode is disabled.
Disable Brave shields, and notice 3D mode is enabled.

Actual Result (gifs and screenshots are welcome!):


Expected result:
Well, if Brave is just blocking a device recognition script, it seems it would not block this, but perhaps it is not just a recognition script.
Reproduces how often:
Always.
Operating System and Brave Version(See the About Brave page in the main menu):
Version 0.61.52 Chromium: 73.0.3683.86 (Official Build) (64-bit), Windows 10

Additional Information:

0 Likes

#2

It very likely is simply canvasing your screen to determine how to render the map on-screen. Allow device recognition for Google maps and your issue should be resolved.

0 Likes