Brave v1.16.68: change settings on Google Maps to 3D & turn on JavaScript on all sites?

Hello folks,

I’d like to know how can I change Google Maps to 3D?

How do I turn on JavaScripts on all websites?

Since the update it has changed some of my settings, I’ve searched how to change them but turning off shields didn’t work for Google Maps to 3D view. Are there any other suggestions?

OS: Windows 10 Pro
Browser: Brave 1.16.68
Laptop: HP 8570w

Thank you.

6 Likes

brave://settings/shields make sure that the block script is disabled
also check brave://settings/content/javascript that the site you check is not blocked there

does turning the shield off make difference

hope that help and have a nice day

1 Like

justsomeone1, thank you for the suggestion on JavaScript, I did some more tinkering and found that to turn on JavaScript on all websites is to turn off block scripts.

For turning on and off shields on Google Maps didn’t help it’s still the same. Is there a direct tech support for Brave that I can enter a question to?

Thanks.

1 Like

you welcome @jstROM

i will ask one of the team to help you @jstROM please notice it still weekend so it will take time to get response

could you help us here @Mattches

and have a nice day both of you

1 Like

Here just to give a + 1 on this issue. Since last update, Maps is defaulting to Lite mode, unable to use the 3D even when using the force http://maps.google.com/maps?force=webgl

Message I get is We’re sorry, only the lite mode of the new Google Maps is available at this time

Having to use Chrome for this :frowning:

Thanks

1 Like

could you check this @fanboynz

and have a nice day everyone

1 Like

Does https://webglsamples.org/aquarium/aquarium.html work @RenanAz ?

Ensure you have Hardware Acceleration with webgl websites in brave://settings/system

2 Likes

Im a bit dizzy from all the fish, but yes, it works even with 30k fishes in screen.

Settings are set correctly.
I just reset it all just in case and aside from losing a bunch of tabs in other windows, no positive change.

Any ideas @fanboynz ? :frowning: I hate having to go back to Chrome to do stuff.
Thanks in advance for your help!

I have this issue too. I’m on version
Version 1.16.72 Chromium: 86.0.4240.183 (Official Build) (x86_64)
Mac OS version 10.14.6

I really would like this fixed.

Can @scutts @RenanAz check Brave Nightly, does it help?

Thanks everyone that responded to this post, I guess will have to wait for the next update for Brave to figure this out. It’s back to switch back and forth with Chrome and that sucks.

What’s awkward is whenever I turn off Shields on any website it abruptly force quit Brave.

My Shield settings:

  • Trackers & Ads Blocked = Aggressively
  • Connections upgraded to HTTPS = ON
  • Scripts Blocked = OFF
  • Across-Site Cookies Blocked
  • Fingerprinting Blocked = STANDARD

Any other suggestions why this is happening?

Thank you.

Can you test in Brave Nightly @jstROM

Hi @fanboynz, nightly works for me. what changed?

I believe is related to https://github.com/brave/brave-core/pull/7026 @scutts

@fanboynz, I’ll give a shot, thanks.

@fanboynz, I’ve tried out Brave Nightly Browser it worked like a charm, thank you so very much, worked like a charm.

I can confirm the problem in:

Brave: 1.16.76 Chromium: 86.0.4240.198 (Official Build) (64-bit)

Google Maps appears pixelated, and trying to force the 3D version, as described here results in an error message. This appears to be the same problem.

I can also confirm that the problem does not occur in Nightly, in:

Brave: 1.19.2 Chromium: 87.0.4280.49 (Official Build) nightly (64-bit)

Hope that helps!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.