Brave not using hardware acceleration

Description of the issue:
Unable to browse Google maps in 3D mode in Brave, on MacOS 10.15.7 and ubuntu 20.
3D works in Chrome on both platforms. I’ve tried enabling/disabling “hardware acceleration” in Brave settings and relaunching, no good, the 3D option is still not enabled in google maps.

Exact URL of the website in question:
For example: https://goo.gl/maps/fuaofKyAukTfbutx6

Did the issue present with default Shields settings? (yes/no)

Does the site function as expected when Shields are turned off?
Turned off Shields, same behavior.

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
no
Does the site work as expected when using Chrome?
yes.
Brave version (check About Brave):
1.31.88

What error message are you receiving? On linux, it may depend on which GPU driver you’re also running here.

I did not mention any error message. Google maps simply fails to enable or show the ‘3D’ option, restricting viewing to the flat 2D mode. It’s like the browser is failing to detect that hardware acceleration is available. In other browsers, turning off “Use hardware acceleration” disables 3D mode, turning it on enables it. Not in Brave.