eBay sign-in crashes the browser

Description of the issue:
Signing into eBay crashes the browser.
Works great on everything else so far.

**Steps to Reproduce: **

  1. Clicking on my bookmark for My eBay Summary
  2. Trying to verify the captcha at https://www.ebay.com/myb/Summary (if I’m already verified, it just goes ahead and crashes.)
  3. Trying to sign in from the home page.
  4. Any other attempt to get the the Summary page.

Actual Result (gifs and screenshots are welcome!):
I get a crash report.

Expected result:
Reaching the summary page or being allowed to sign in.

Reproduces how often:

Operating System and Brave Version
Version 1.12.114 Chromium: 84.0.4147.135 (Official Build) (64-bit)
Mac OS X Sierra 10.12.6

Additional Information:
In the closed topic “Brave crashes after opening certain sites”, davidjmathena had best answer but doesn’t work in my case.
Tried resetting browser. Disabled all security measures. Removed my one installed extension. Closed all other browsers.
I have the text to the crash report if you need it.

I was able to authenticate into my Ebay account via the page you linked to. To confirm, you did try clear your cache/browsing data?

I don’t know if that got done, but I will give it a try. Yesterday was the first day I’ve used it.

OK, cleared all the cached and browsing data. Still crashes.

Perhaps it’s OS specific? Not crashing on a later OS, etc?

I’m testing on both macOS and Windows and don’t see that behavior, however you do seem to be running an older version of macOS which may be the issue. Can you try downloading/installing our Beta build and see if you get the same crash when using it?

OK, I will try that. Yes, I’m using Sierra because it runs really well on my 2016 MacBook Pro.

I did as you suggested, no luck with Sierra, but I was able to get both the current Mac version and the beta of Brave to sign in to ebay on my older Mac that runs El Capitan, with shields up. On the Mac running Sierra however, the beta crashes on launch, with nothing else running, and even after a system restart.

I’m having a similar issue, except that I can’t even type a username into the blank. I can’t get as far as the captcha. Ridiculous!

So you are able to get Brave and/or ebay working just fine on your macOS running El Captain but not on Sierra? This doesn’t surprise me given how old both of these OS are but it still should run okay.

Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

OR, if the browser crashes before you can reach this option:

Open the Terminal and enter this command: open -a "Brave browser.app" --args --disable-gpu

I have been having the same problem for two weeks. I have had this problem in the past after EBAY upgraded it s systems but it never lasted this long. I know they did upgrade their software/system about two weeks ago because many complained that regular sales (auctions) dropped to zero with no explanation. (found on their ebay support chat. This has been a PATTERN over the years that I have found) I can access ebay on firefox, but I really hate that. I have also tried dropping shields, and my Brave is set to AUTO dump cache on shut down. as with every other system glitch of importance, ebay has, in the past, blamed it on END USER software, o/s or incompetence I CAN TELL YOU that this repeated problem with ebay happens according to your COUNTRY or the servers in/out of that country OR STATE, so maybe because brave is so private?

apparently ebay is probing numerous ports on your pc now. I hate this whole data mining JUNK. I used to use Zone Alarm and it was great till they sold it, now its a total internet slut. This is the primary I reason I use Brave. PRIVACY. (As much as possible) Here s a link to Forbes Magazine with the article. https://www.forbes.com/sites/daveywinder/2020/05/25/did-you-know-ebay-is-probing-your-computer-heres-how-to-stop-it-windows-privacy-chrome-firefox-web-browser/#67046df43a92

I turned off Hardware Acceleration in the non-beta version of Brave on your suggestion. It still crashes after I’ve verified the captcha, and the Sign-in page does show up for a half second before crashing.

In Sierra, I tried disengaging Automatic Graphics Switching in System Prefs, but doing so only forces the computer to use only the discrete (accelerated) GPU. So it may be that there’s no easy way to try this. There may be a way to x out the discrete chip in Terminal, but I haven’t found it yet.

Thanks! Interesting.

This may seem weird but do you by chance have the page “zoomed in”/enhanced at all? If so, can you try resetting to 100% and see if you’re able to complete the captcha without the browser crashing?

I would also try clearing all cache/browsing data (starting with eBay) and see if the issue persists.

It’s not the captcha that crashes it. When I am asked to verify, it gives me a captcha to do. After that, I get the sign-in page for a half second, then it crashes. Normally I do zoom the pages a bit, so this time I set the page to actual size in the view menu. Still crashed. Reset all browser / cache data, checked page size. Crashed.
Went to basic eBay page which doesn’t crash. Turned off shields. Cleared cache again and then had to turn shields off again. Went to ‘my eBay summary’ page which requires sign-in. Crashes after a half second. Pages were always at actual size.

Tried again, cleared cache, checked page size, opened ebay.com (no crash), turned off shields, went to ‘my eBay’ page, crash.

Can send the logs if that would be helpful.

1 Like

Yes – if you can go to brave://crashes and ensure that you hit the Send now option so that we receive them (note that you only have to do this if Automatic crash reporting is not enabled). I’ll dig in a bit further, although that’s a very strange issue to have. Would you mind also testing a new profile (Menu --> Create new profile) and seeing if the issue appears there as well?

OK, I sent that. Crash from Tues Aug 25 at 10:47:38 PM Eastern.
Created second profile, shields off on ebay.com, actual size window, crashes at sign-in screen. Sent that. Crash from Tuesday, August 25, 2020 at 11:23:59 PM

Page loads just fine on my older MacBook Pro with El Capitan, no problems at all.

Today I was able to sign in to ebay using Brave with no problem, so perhaps ebay has changed something with the way the site works. Fri Sep 4: Oops! my bad! Brave auto-updated and I didn’t realize it. So apparently that bug got fixed. Good show!

1 Like