Ebay.com causes Brave to freeze for about 30 seconds

Problem

  • ebay.com causes Brave to pause for about 20-30 seconds when you first load the page
  • it appears to show at the bottom left “waiting for src.ebay-us.com
  • it freezes the entire page, no hovers work, you can’t type, etc
  • after that time it clears and works as usual
  • it then never freezes again during that ‘session’ I guess
  • if you then turn off “shields up” then this does not happen, it loads immediately
  • then if you turn “shields up” back on, it doesnt seem to occur again, even with a refresh or new tab
  • but I have had this happen may times

So basically I don’t know how often that src.ebay-us.com is loaded, or if it’s cached or whatever, so I don’t know the exact combo of new tabs, shields up or dowm or whatever. But frequently this happens, and I very very rarely bounce the entire browser, so it does start to reoccur without that. Maybe its time related, not sure.

  • easily reproduce-able for me
  • Chrome and Firefox don’t have this problem at all

Additional Info

  • I realized I didn’t have the latest Brave, so I updated it relaunched and ebay.com didn’t freeze.
  • But if I had to guess, I don’t think this version fixed it, I think this might be a timing thing (saved cache?) versus a tab reload thing. I will try every few hours and see if I can reproduce.
  • If you can tell me how to do a more reliable test I will.

Machine:
Macbook 2015, macOS 10.14.6 (18G87
Brave: [Version 1.12.114 Chromium: 84.0.4147.135 (Official Build) (64-bit)]

Happy to try other things if you’all like.

I have the same problem MacBook Air 2011, macOs 10.14.3 Brave: [Version 1.12.114 Chromium: 84.0.4147.135 (Official Build) (64-bit)]

I have same problem using several different computers (MacBook, Acer, Asus) each running Linux. (Version 1.13.82 Chromium: 85.0.4183.83 (Official Build) (64-bit)])

I’ve noticed that the Brave Shields icon shows “13” when its frozen, but only “11” when ebay loads normally. Its like the shields blocks something extra and causes everything to freeze

Thank you for reporting this. The assertion that the hiccup is a particular item(s) being blocked by Shields is probably accurate, although I can’t say for sure at this time. I do see the same freeze as described – except in my case it only lasts a few seconds ~3-5.

I’m CCing @fanboynz for more information on this.

Ebay fix is incoming, give it another 24hrs or so.

A new fix incoming @cswanson @sergiy23

Good news dear friend !