Dropbox website not working on Brave browser

Brave doesn’t let me log in to Dropbox.com.

I recorded a video of what specifically happens when I try to log in: https://youtu.be/OUVDi_gm5Bs

Few things I tried:

  1. Removing cookies
  2. Disabling Brave Shield (in the video)
  3. Disabling every addon on the browser.

The version of Brave: Versio 0.68.132 Chromium: 76.0.3809.132. Which should be the newest.

Every other browser works except Brave.

What happens if you click on the Dropbox icon in your system tray and then click on the globe icon third from right at the top (the icon has a tooltip saying “Open dropbox.com”). On my system that opens Dropbox for me already logged in.

Hi Nick sorry for the late reply.
I tried what you told, sadly… It didn’t work either :confused: .
When i click the globe button I get prompted to Dropbox site saying: “Your session has expired. Please sign back in.”
It keeps saying that even though i try to login from there.

I’m curious about how you landed on that page – I mean, obviously I can see you went to dropbox.com as shown in the video, but when I go there I land here:

In the image above, I clicked the Sign in button circled which directs me to dropbox.com/login:

Attempting to login from here is successful, both using email/password or the Google auth. option. I’m wondering if the issue is specific to the page you’re landing on in the image above?

Hi, yes indeed I have a different site when I press Sign in.

When I tried what @NickJP suggested it did bring me to the same site that you were in your picture. But it prompts me with “Your session has expired. Please sign back in.” Over and over again when I try to log in.

Oh, and it seems like when I click your link to dropbox.com/login it does go to the same site as you but when I try to login it sends me back to the same page as in my video.

This is getting weirder and weirder.

Yes, that is very strange indeed.
Can you try clearing your cache/site data (at least for Dropbox domains) and then revisit/try to authenticate again?
Go to https://dropbox.com --> Lock icon --> Site Settings --> Clear data
If that doesn’t work, you may want to try cleaning your cache/data for all sites to see if that helps as well.

I just realized I should’ve been precise with my wording on the original post, I did clear the cache/cookies, but only from Dropbox. After deleting my whole browser history… It worked, I can’t believe how I didn’t try this before.

So now it’s finally working! Thank you @Mattches and everyone else who helped!:slight_smile:

1 Like

My pleasure! Glad you got it working – enjoy your privacy :slight_smile:

1 Like