Cannot login to Dropbox

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting


Description of the issue:
How can this issue be reproduced?

  1. Brave version 0.70.122
  2. Login to Dropbox not accepted
  3. Can login with other browsers (Safari, Chrome)
  4. OS Mac Mojave, latest update

Expected result:

Brave Version( 0.70.122`):

Additional Information:

1 Like

@DaddyBoo did you try to login with email or using “Sign in with Google” button?

I always login using my use ID (email) and password. I do not login using my Google ID.

@DaddyBoo,
I was able to login without issue, as well as create an account without issue. Can you tell me what happened when you tried to login? You mention that it’s “not accepted” but I’m not entirely sure what that entails.

It returns to the page where you hit the lines to login. Basically the Brave homepage for Dropbox. See screenshot
attached. It never goes into Dropbox.

@DaddyBoo,
Can you try clearing your cache and site data for Dropbox, then logging in again? Also, are you using Dropbox business or basic?

Cleared the cache. It only takes me to Business which I don’t have. See attached. I can’t get to the standard login site.

Have you tried contacting DropBox regarding this issue? Just a thought. Or do we have any reports that DB has some compatibility problems with Brave?

@DaddyBoo,
From that page, if you click on get Dropbox Basic here:

Does it return you to the login screen where you first entered your credentials?

I don’t see anywhere that Dropbox has support while logged in. I did see an old board that people were having issues with Brave and Dropbox. Not sure how to contact Dropbox but will continue to pursue that. Works fine with Safari, Chrome and Firefox.

Chatting with Dropbox support now.

If I do that it takes me to where you can sign up, not a login.

@DaddyBoo,
Can you try logging into dropbox using a Private window session?

never tried to do a private window on the computer, only handheld devices. I don’t know how to do that.

@DaddyBoo,
To open a Private window, go to main menu --> Private Window.

Incidentally, as I was making a short recording of these steps for you to follow, I actually encountered the same page redirect you mentioned above. Can you instead try to navigate directly to the url https://dropbox.com/login and try to login again? I would try in both a standard tab, and if it doesn’t work, try doing so in a Private window.

@DaddyBoo Any luck with their support team?

Had a good chat session. Waiting on their follow up. We’ll see and I will report when I hear anything. Thanks for your suggestions. Just very weird that Brave only takes me to the business site.

Dan Shapiro

I’ve been having the same issue with Dropbox since yesterday. I removed all cache and cookies, and also turned off the Brave shields to the dropbox website. I logged in using Microsoft Edge this morning with no problem, but it isn’t working with Brave.

I just did that, and it isn’t working. It keeps taking me back to the same page – not letting me log in. It works fine in Microsoft Edge, but not Brave. I use Brave a lot with Dropbox, so I’m not sure why this issue only started since last week.

Private window doesn’t make any difference.