Downloads not working, shows # in mac OS dock icon but file is nonexistent

“save image as” does not work for me either.

additional info, any websites that have a file upload dialog, that dialog is not showing up either, I believe its related to this.

Hmmm… I just tested this and I have the same issue. I usually just drag and drop and it works, but the upload buttons don’t do anything. I’ve tried this on Frame, Vimeo and Dropbox so far. Again, I can drag and drop to upload, but I cannot use the upload button to just like Aleksander.

Same situation here, drag and drop works but actual upload prompts (with browse option) are gone.

Any updates or resolutions available?

@AleksanderSuave,
Still looking into it. The fact that it was not working but is now working (at least for you) but only for some cases but not all makes it additionally confusing.

I’m curious if you (or anyone here encountering this) have any extensions installed at this time?

@Mattches The only extension I have now is LastPass.

Same issue for me here. on Brave v1.32.155. However, everything works as expected in Brave Beta 1.34.54.

I am having the same issue as described here.

I am using:
macOS Monterey (Version 12.0.1)
Brave 1.32.113 (Version 1.32.113 Chromium: 96.0.4664.45 (Official Build) (x86_64))

Extensions:
Save All Resources (Full access required)
LinkedHub (No access required)
Neutral Face Emoji Tools (No access required)

I have tried a different profile, and I still encounter this issue.

Any file I attempt to download increases the number on the Brave icon on the mac dock. The circle always appears blue, as in the download never completes.

Right click “saving images as” doesn’t work.

At no point has a file ever finished downloading no matter the duration that I wait.

I never get a prompt to select the location to save the file. If I make it so Brave automatically downloads to my downloads folder, they still do not finish, or even start

I have not been able to download for about a month now. I started encountering this issue after I upgraded to macOS Monterey.

@Mattches I think I have found the issue.

So I started having issues with Adobe doing the same thing where I couldn’t save or choose destinations on my outputs. This all started after I updated to Monterey. Well, I am using two monitors. I noticed on Adobe that if I went to only one monitor, I could save and everything.

I tested this theory out on Brave and when I went to one monitor, I could save. As soon as I plugged back in the second monitor, I can’t save. It goes back to showing the number and as if it is saving. I looked to see if the dialogue box shows up somewhere or anything, and no dialogue box.

But yeah, having dual monitors seems to affect it for me. Not sure about the others.

1 Like

In case this is helpful to anyone else. I was working on a Chrome extension and just encountered this issue. (My chrome extension uses the chrome.downloads.download() API with saveAs: true)

  • Downloads were working, I was iterating on functionality and triggering downloads interactively with the extension, getting prompted properly, downloading files properly, etc.
  • In the parent function of the function that calls chrome.downloads.download, I added a chrome.runtime.sendMessage() call
  • I saved the file, reloaded the chrome extension. Now messages were getting sent, but the downloads were behaving as above - no UX, no errors in the chrome API, incrementing download IDs, inability to call chrome.downloads.show or chrome.downloads.open, etc.
  • Disabled message sending. Still no fix.
  • Moreover, I noticed a trove of hidden files in the Downloads folder consistent with an “in progress download” but no in progress downloads noted anywhere within Brave
  • I am not sure which version of Brave I was on, but I had already downloaded the latest version, so I clicked “Relaunch”
  • Prompted that “downloads are in progress, are you sure you want to Restart”?

Now the issue is fixed on new version / after relaunch. Now on:

Version 1.33.106 Chromium: 96.0.4664.110 (Official Build) (x86_64)

(I also re-enabled messages after upgrading, and things still seem to be fixed)

Very thankful for this thread though - I was beginning to question my sanity :smile:

1 Like

I just wanted to give an update. So I did another software update to macOS Monterey ver. 12.1 and now I can right click and save. That also solved the issue I was having with Adobe. So yeah, Apple’s at it again haha.

I didn’t do anything differently other than that update. I hope everyone else gets it solved by this update.

1 Like

Hi, I have the same issue - downloading is not working without any message at M1 powered macbook air with the latest version of brave and 12.1 latest monterey.

What is also strange, that I could not even see the menu and log in or signup to brave community support…

I have unchecked the download location selection and disabled widevine in the settings - this solved the problem, now I can login, see the menu and download files. Hope this can help.
Csaba

I still have the issue unfortunately, when I want to download pdf-s. It does not save pdfs nor in new profile.

I frequently have this issue. I am on an M1 Macbook Air, macOS 12.1, Brave
Version 1.33.106 Chromium: 96.0.4664.110 (Official Build) (arm64).

Everything works fine for a time. Then, the download save as dialog does not appear for an expected download, and the dock notification does tick up and a partial download file shows up in the default downloads location. Restarting Brave consistently fixes the issue… temporarily.

Also having this problem. M1 Macbook Air, Mac OS 12.1 - it started when I upgraded to Monterey the week after Christmas. So that was straight into OS 12.1 and whatever Brave version was current at the time. There’s been a couple of Brave updates since then and the issue has carried through all of them.

After reading through this thread last night, I toggled off the “ask where to save” setting and so far I’ve been able to download a couple of files. Strangely, sometimes I’m still asked where to save even though the toggle remains off.