Download windows won't show up

Description of the issue:
When i download a file, wether with a left click or a right click save under, the download window won’t show up at all.
If i try to click anywhere I hear an error sound and i can only do two things :

  • Hit enter to download the file in a random place
  • hit escape to close the invisible window and get control back

I also noticed the same issue if i have to upload a file to a web interface : the browsing window won’t show up. The only way i can upload, is to drag and drop, when possible.

How can this issue be reproduced?

  1. Downloading any file or picture

Expected result:
See a browsing window popup to be able to chose where i wanna download the file

Brave Version( check About Brave):

Additional Information:
I tried, turning all my extensions off and in private mode.
I also tried uninstalling brave, rebooting the computer and installing it back.
I’m on windows 10


Maybe change the destination directory a few times, and toggle the switch:

In a Brave Browser > New Window, go to: brave://settings/?search=ask+where

Disable / Enable: Ask where to save each file before downloading

Shake things up a bit.

Also go to: brave://settings/content

Scroll down to “Additional permissions” . . . and set:

  • Automatic downloads: Sites can ask to automatically download multiple files
  • Protocol handlers: Don't allow sites to handle protocols
  • File editing: Don't allow sites to edit files or folders on your device
  • Clipboard: Don't allow sites to see text or images on your clipboard
  • Window placement: Sites can ask to use info about your screens to open and place windows

Scroll down to “Content” . . . and set:

  • Pop-ups and redirects: Don't allow sites to send pop-ups or use redirects

Scroll down to Additional content settings . . . and set:

  • PDF documents: Open PDFs in Brave

Because, I have found little trouble with that, first Opening a PDF file via Brave Browser’s built-in PDF handler . . . and then downloading the PDF file.

Also, go to: brave://settings/shields

Disable: Auto-redirect AMP pages

Thank you very much for your help.
I’ve done everything.
For the options that were correctly set, i re toggled them but unfortunately that didn’t solve my issue. :s

Is any antivirus or other security software installed?

Does the issue occur if you create a new profile and try it in that profile? (Make sure your original profile does not have any open windows; only the new profile should be open.)


A simple text file for you to download. The contents are one word: “test”

testFile.txt (4 Bytes)

Download that, and let us know what happens.

The window that I see, appears to be a Mac OS Finder object:

So Brave Browser probably makes a call to the Mac OS.

Hi guys,

i tried creating a new profile and shutting windows of other profiles but sme issue occurs.
I di have an antivirus, but it’s always been here and Brave used to work correctly on this computer.

I also have another computer with Brave synced to the one with the issue same antivirus, no problem.

Weird right ?


Maybe try a Safe Mode startup:

. . . and then test.


Is this other computer running the same OS/Brave version? To me this seems like some sort of permissions issue you’re encountering that’s blocking downloads. But having said that, I’m not actually sure what/where this permission is being blocked. Do you have any extensions installed (in either profile) on the machine where you’re encountering this issue?

Thanks for your answers.
The other computer is with the same Brave version but on Windows 7. It has the exact same extensions.
FYI, on the W10 computer, the one with the issue, i tried to desactivate all extensions with no luck.

Guys… I’m so embarrased. I just figured out what was happening.

i have a second screen on this computed. It’s mostly off but for some reason even if it was off, the download window was showing up on that second screen.

I turned it on, moved the windows back to my main screen and the problem is solved.

Thank you very much for your help !


Related issue:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.