How to view a PDF in Brave browser window without having to download file

Description of the issue:
When clicking on a link to a PDF Brave prompts me to download the file. How can I get Brave to view the file instead of downloading the file?

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Click on a PDF link

Actual Result (gifs and screenshots are welcome!):
Download dialog is displayed

Expected result:
PDF should open in browser window

Reproduces how often:
Every time I click on a PDF link

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10
Brave Version 0.68.132 Chromium: 76.0.3809.132 (Official Build) (64-bit)

Additional Information:
I installed a free PDF viewer extension and that doesn’t work either

chrome://settings/content/pdfDocuments

Slide that off.

I do have that off. I even turned it on, restarted the browser, turned it off again, restarted again and it still doesn’t work.

Any other ideas?

Press Windows key + R to open the run dialog.
Paste ms-settings:defaultapps into the box and press Enter.
Scroll down to Set defaults by app and click it.
Select Brave in the programs list on the left side pane.
At the bottom select Choose defaults for this program
Select pdf from the list and click Save on the bottom right.

Make sure you have the slider off in the Brave settings.

You can also right click a .pdf file on your computer and open with and choose Brave. And select Always use this app to open .pdf files to set it as the default.

If it isn’t there, select the Choose another app option.
If it isn’t there either, click More apps and scroll the list to find Brave.
If it isn’t there either, scroll to the bottom to find Look for another app on this PC and click it, then navigate to C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application and finally click the brave.exe executable.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.