Disabling Safe Browsing no longer works

Since one of the latest major updates the Safe Browsing option seems to block executable downloads even when disabled, I’ve double checked if this is the same for chromium, chrome, and a couple of other chromium based browsers, but brave seems to be the only one doing this for me…
I’ve tried enabling/disabling safe browsing a couple of times, but it keeps blocking executable file downloads, for example .exe and .msi
I’m on windows desktop stable build btw, latest version.
It’s not even working 50/50, it just straight up doesn’t work at all, ever

Ps I’m hoping I’m posting this in the correct section as I cannot seem to find a bug reporting section on the forum

I will suggest trying the same in a new profile. Create one by clicking on the Hamburger Menu near the right corner of the screen / on the right to the URL bar.
Turn off the secure download in settings
If it doesn’t happen on the new profile, then something is wrong with your original profile.

Also when testing, do not add any extensions or anything in the new profile. Let it be a completely fresh profile.