Safe Browsing gets turned off automatically

In the section of Privacy and Security, under the Security Check, the Safe Browsing Option gets turned off automatically, and becuase of this my Search Engine “Ecosia” always shows “CHECKING WITH SYSTEM BEFORE ACCESSING THE SITE”, and error code is like EF-002. I currently do not know, what it means, but this issue needs to be fixed.

1 Like

Hello @Damon_Salvatore, thank you for reaching us out. Have you updated to the latest version? What kind of device and OS are you using? If on desktop, try going to > Safe Search and change the option from there. Hope it helps.


Hey @Jarc-1107 Yes, my Beta Browser is upto date, and the device is a laptop and OS is Windows 11 Pro.

I’m seeing the same issue on my pc. I have the latest stable build

It worked as intended on my end using different search engines. Can you please share a screenshot with the specific issue or error message you are getting so we can further investigate. Thanks in advance.

Same here. I encounter this bug a week ago I guess

Same issue here. Currently on Version 1.48.171 and safe browsing keeps turning off every few hours. Reinstalled and reset multiple times. Done a ton of malware scans as I assumed it was being disabled for malicious reasons. Just found reports of this here and seems it’s just a rather serious bug.
Hopefully it gets fixed soon as I’m having to use another browser for now, not risking having no security.

Hello again @Damon_Salvatore, I am following up this case. Is this still an issue for you?

Hi, I’m currently using Version 1.48.171 for Windows 11 and I can confirm that Safe Browsing is still reverting to “No Protection” for me.

Just done some testing, safe browsing does continue to function even after the bug occurs and it displays it is disabled. So it still is actually working, just it appears to be disabled.
I enabled then disabled it, that actually disabled it. Enabling it then it self disabling does not actually disable the functionality.

Hi @Jarc-1107 Thanks for reaching out!!
The solution seems to be resolved for now.

Thanks for helping!!

How did you solve the bug?

Well, Fun Fact- I didn’t!! The Issue seems to be resolved by @Jarc-1107, as he has connected with the developers and the issue seems to be resolved.

Happy to help. Best Regards.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.