Disable URL suggestions

Since a recent release, typing in the URL bar suggests some common URL completions. For example, if I type in “m”, it suggests “msn.com”. The suggestions appear even when “Show Search Suggestions” is disabled.

I browse exclusively in private mode, so I have no saved history, and these suggestions are all irrelevant to me. I’d like a setting to be able to toggle them off.

1 Like

@anon1255531 @toml and @mattches would help

Have been annoyed by the same since I started using Brave six months ago. The option: Use a prediction service to help complete searches and URLs typed in the address bar, is off and in Brave://flags none of the tested omnibox settings brings about changes.

Behaviour resembles what a browser hijack looks like. I removed all add-ons before reset to default settings.


Perhaps a moderator can move topic to a more suitable category because OP is on iOS. Me on Windows 10.

bumping query
@Mattches ?

Windows 10 version 0.69.132 Chromium: 77.0.3865.90 (Official Build) (64-bit)

Is there anyone who has the answer to this? Annoying as girls with fashionist glasses.

Same here - very, very annoying. PLEASE fix this BUG!

Brave 1.0.1 64-bit, running on Linux Mint 19.2 xfce, 64-bit.

1 Like

Rephrasing: anyone of the Brave team who even cares to reply? Users have been asking for three months you see… :sleeping:

yea we can completely stop the url suggestions of chrome and other browser will be similar , if you want to delete url suggestions on chrome, you may read this link