Disable hidden http in address bar

I go to brave.com. The address bar shows brave.com. I copy brave.com. I paste brave.com, but what pastes isn’t what I copied. In an attempt to look good (or whatever reasoning behind hiding the http://), the copy/paste function has effectively been BROKEN. How can I make it so when I copy something, the browser copies what I copy? :expressionless:

The browser does copy what you copy. When you see this text in the Address bar:
What you’re actually copying is this:

The browser (and machine) are doing exactly as intended. That said, if you want to force Brave to show the full URL, you can go to brave://flags and search for a flag called:
Set this to disabled. You may also have to do the same for the #omnibox-ui-hide-steady-state-url-scheme flag as well but I’m unsure.

This way, once disabled, you should always see the full URL displayed in the address bar.

1 Like

Thanks, that worked (for now). brave://flags redirected to chrome://flags, and the only thing on that entire page with the word “hide” was Omnibox UI Hide Steady-State URL Scheme and Trivial Subdomains. I set this to disabled.

I am a little confused about your verbiage though. “The browser does copy what you copy”…

But then right after that you say What you’re actually copying is this:

So, it does not copy what I select and copy. It copies more than what I copy. However, you are correct in that it is doing exactly what it is INTENDED. (PROGRAMMED).

Thanks again.

1 Like