Display full URL

Hello,

I have tried to have the Brave browser display the full URL but what I have found as solutions seems to be outdated for example brave://flags. I search for them and there is none of the following:
#omnibox-ui-hide-steady-state-url-trivial-subdomains
#omnibox-ui-hide-steady-state-url-scheme

To clarify I just want the full URL displayed by default without having to go into the search bar and double click it. The abbreviation is very annoying. I must be missing something.

Any help would be appreciated.

Regards
Deirdre

Mac OS 10.14.6
Bave Version 0.70.121 Chromium: 78.0.3904.70 (Official Build) (64-bit)

3 Likes

@Deirdre,
Thank you for reaching out.
After some digging, it seems as though these flags have been removed from the Chromium backend entirely. At this time there doesn’t seem to be a way to work around this but I’ll make sure to bring this up to the team – I’ve had lots of people ask how to show the full URL and subsequently used the flags you listed to do so.

Apologies for the inconvenience.

1 Like

Thanks a million for the quick response! I’ll leave it with you so.

1 Like

i did this in a previous release on chrome it worked but as stated above i can only find GitHub issues on it
and brave does display the full url though it does not include a prefix like http or else
It is good as it allows for more text of the url be visible in the url bar

I disagree. Not displaying https:// or http:// I consider an issue as a web developer. Those are in itself integral parts of a full URL.

1 Like

agree to it too but there isn’t a way around this
fingers crossed for a fix :slight_smile:

Ha ha
patience and persistence
Is the way to go !
:blush:

Agreed. And I got this to work a while ago. The changes stayed… but I can’t see or remember how I did it. I think it had to do with an extensions, and launching Brave with the command line flag --extensions-on-chrome-urls
I’ll keep looking.

image

image

ofcourse keep looking !
brave may eventually develop a vaccine for the epidemic
Let’s find the cure. :wink:

I found by entering this into the omnibar…
chrome://local-state/
…there is an entry therein:

"browser": {
      "enabled_labs_experiments": [ "extensions-on-chrome-urls", "omnibox-ui-hide-steady-state-url-scheme@2", "omnibox-ui-hide-steady-state-url-trivial-subdomains@2" ],
      "last_redirect_origin": ""
   }

So perhaps you can manually enter those elements and restart brave? I don’t know where you’d find that file or data in order to enter them manually.

Another update… the file, on Mac anyway, is here: /Users/Jules/Library/Application Support/BraveSoftware/Brave-Browser/Local State.
I suggest quitting the browser and making a backup of that file before editing that file.

I got the hint from:

Windows…
Local\Google\Chrome\User Data\Local State
per:
https://www.askvg.com/fix-you-enabled-some-flags-on-chrome-flags-page-and-google-chrome-no-longer-opens/

cannot get through this as of latest updates removing things
i am on it will discuss it here sooner.:stuck_out_tongue_closed_eyes:

I been sort of annoyed by this as well. Glad to hear that the team will hear about it and hopefully fix it. I also think that the http/https is a part of the URL so not having it strange. Not sure why someone would remove that to begin with.

I don’t see any purpose to hide it either. Maybe to simplify the url for those unfamiliar. But still, it’s an odd lack of transparency.

I didn’t mind not seeing the protocol since the lock icon conveys the same message. It’s the ‘trivial’ subdomain removal that got me. Next would removing everything but the domain name, which is default behavior in Safari.

@Deirdre have you tried my fix above? Did it work?

Aye, I know the wee lock icon but when you are developing I prefer seeing the details as well… Not that the icon isn’t just as relevant. The ‘!’ when you push a website from local development to alert you of mixed content is certainly useful. Safari doesn’t even have favicons nor is it anywhere near secure. Removing the subdomain is just a nuisance.