Device limit reached on 2 devices only

I only have 1 desktop and 1 laptop. why does it says i have reached device limit??? I can’t connect my uphold account anymore.

1 Like

Surprised there is no helpline we could talk to about issues.


Have you ever reformatted one of your devices or deleted and reinstalled brave? If so every re download of brave counts as a new device limit.

I did for my desktop. But that’s still just 1 device??? Why would they count that as more than 1???

Should not have counted for more than 1 unless some mistake happened. You sure you never deleted and reinstalled as well on the laptop? I know it is probably hard to remember, but was there ever times on PC or laptop you tried deleting and reinstalling due to some problem like a freeze or to fix something? Or have you tried out any beta or nightly builds? Those would also count as well.

I just noticed I misread that a bit. It does count as more than 1 because for every New brave device you connect to Uphold it counts as 1. So in your case PC, PC re download and laptop are now at 3/4 device limits. But there is still some other fourth device out there which is unaccounted for and since you tried reconnecting another device to Uphold that is the 5th device apparently and they only allow 4 max lifetime devices. I understand the PC may be the same PC with no changes like hardware etc. But to brave and Uphold (possibly Gemini as well) they only allow 4 brave downloads regardless of what it is downloaded on. This includes PC, laptops, tablets, phones and Virtual machines I supposed, however, brave does not recommend using virtual machines. And any different brave browsers such as beta or nightly also count towards a device limit.

Yes I may have forgotten what I did to either devices but I am pretty sure I have only used Brave on my laptop and desktop. It sucks they have no solution for this.

Just a matter of time now.

1 Like

There are literally 4 devices in my household. and at the moment only one has successful uphold connection, all others show “limit reached”. What the actual hell is going on? All I did was normal auto-update Brave. Note: all 4 devices had working uphold linked to Brave in the past.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.