Desktop shortcuts not functional

When Brave is my default browser, none of my desktop shortcuts work. They work fine when I set another browser (Chrome, Firefox) as default, but not when Brave is the default.

I can start Brave by clicking on it directly and then key in the website address and that works, but not when pointed to by a shortcut.

I have tried resetting Brave to its default settings. I have tried rebooting. No luck.

In previous versions of Brave, I think this worked fine (not sure - haven’t tried to use it in a while), but not now.

Is there some Brave setting I need to change to make it work with Desktop shortcuts?

How can this issue be reproduced?

  1. Create a shortcut.
  2. Try it.

Expected result:

Clicking on shortcut should open URL page.

Brave Version( check About Brave):

Version 0.68.132 Chromium: 76.0.3809.132 (Official Build) (64-bit)

Additional Information:

I’m running a legal, activated version of Windows 10 Pro (an upgrade a long time ago from Windows 8), 64-bit version.

Works fine for me. Win10 Pro.

Does Windows report Brave as the default app too?

I’m not surprised that it works for you - can’t understand why it doesn’t work for me. Yes, Brave is my default browser. The only way it executes is if I click on its icon directly. If I use any kind of a shortcut, it does nothing. Also, if anything else needs the browser (like a download of a new version of Flash) and it tries to call the Browser, it doesn’t work.

I’m sure there is something in my system interfering with it but I can’t imagine what it is or how to find out.

When you say “shortcut” you mean creating an icon shortcut right? Not using a keyboard shortcut or script to open your shortcut icon? If the shortcut isn’t working, I’m guessing the path is incorrect?

It’s either the path or it actually isn’t the default browser in Windows. Or are you talking about a shortcut key combo set in the shortcut properties?

This is the path to brave.exe
C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application

Have a look in your windows settings to see if the defaults aren’t overridden.
Press WIndowskey + R to open a run dialog.
Copy paste this ms-settings:defaultappsinto the box and press enter and scroll down to see if Brave is the default browser.

Also, in the default apps settings, scroll down to Set defaults by app and click that.
Then select Brave on the left side pane then click Choose defaults for this program and under protocols, is HTTP and HTTPS set to brave?

When you create a shortcut and put a URL into the box and save it, does the icon change to a Brave icon?

Yes, I’m talking about a desktop shortcut. The URL path is correct. When I change my default browser to, say, Firefox, all of the desktop URL shortcuts I have (and there are several) change to the Firefox logo. Clicking on any of them brings up the Firefox browser and that particular webpage. If I then change the default browser to Brave, all of the desktop URL shortcuts change to the Brave logo but clicking on any of them produces nothing.

If I click on the shortcut to the Brave browser (and your path to that is the same as mine), then it works fine - and I can paste into the URL field any URL I want and it works fine.

But one thing I noticed in looking at my apps, I had TWO Brave apps, one showing the Brave logo and the other one showing a sort of generic CRT screen logo. Wondering if that was the problem, I figured I would uninstall them both, reboot and then reinstall Brave. I was able to uninstall them and reboot and then reinstalled Brave (took a few minutes to do so - it sat on the “Connecting to the Internet screen” for a while before it finished).

I then changed my default browser back to Brave and now everything works as it should - clicking on a desktop URL shortcut brings up the Brave Browser and that webpage. So I may have had a corrupted version of Brave (or something called Brave) and that was the problem.

And I am kicking myself for not checking this before I asked for help. This is not the first time that a corrupted install has caused me grief. Memo to self. If something doesn’t work, reboot WIndows. If it still doesn’t work, uninstall and then reinstall the app. If it still doesn’t work, then ask for help.

Thank you very much for your replies and your time.

1 Like

Awesome! And it’s my pleasure! :+1:

1 Like