Websites do not detect dark mode in Windows 10?


Description of the issue:
How can this issue be reproduced?

  1. Go to any website that automatically switches to dark mode depending on the device settings (e.g. GitHub)
  2. ???
  3. See that it is still using the light theme.

Expected result:
It should have automatically switched to the dark mode.

Brave Version( check About Brave):
Version 1.34.80 Chromium: 97.0.4692.71 (Official Build) (64-bit)

Additional Information:
The browser itself properly detects the dark mode. It’s the websites that do not seem to do so.

Found the fix, it was because I had fingerprint blocking set to aggressive. So I had to go to brave://flags/#brave-dark-mode-block and set it to Disabled to bypass that particular fingerprinting block.