Current Brave will not start up on Macbook

I updated to the current Brave recently to 1.59.120 on my Macbook Pro, since then it will not even open up.
I have uninstalled and re-installed more than once. I click on it and it tries to open but fails everytime.

I click on the icon, after 10-15 seconds I get a notice to say that it would not respond, do i want to send an apple report.

It will not even open up enough for me to get into the settings.

I have lost all my bookmarks to do with my MSc with this issue…
Plus, I just do not like other alt browsers!

Help please!!


If you can’t open the browser, but you want to backup all your bookmarks and other user data, it might be a good idea to install an other Chromium-based browser and then import data from Brave.

Then completely uninstall Brave, with all user data and after installing again, import it from that other Chromium browser you installed.

Thanks, I will try that.
How do I import the data from Brave? Is this the same data as the user data? I may have missed the user data when I installed and reinstalled, maybe thats why it hasnt worked. Can I import the data even if the app doesnt open?
Is it somewhere in a cache on the machine?

Thanks Niknak

When you install a new web browser (like Chrome), you should be asked to import all data from your previous browser. If not, you can always go to the settings and look for an option to import browser data.

I recommend choosing Chrome or any other Chromium browser because Brave is built on Chromium so there wouldn’t be any issues and everything would get imported.

The latest build is actually v1.59.124 — please make sure that is the version you’re trying to install. Additionally, can you try downloading the Beta build to test and see whether or not it opens?

There is no way to import bookmarks from a non-working version of a Brave browser

Hello, I have similar problem, and Beta build won’t work either
Screen Shot 2023-11-19 at 1.19.17 PM

Are you sure? Because that’s the way I usually recover data from corrupt browser installation. Well, I’m on Windows so that’s why it worked in my cases. Might be different on Mac.

Can you please open a new thread and include as much detail about the issue/please fill out all the information requested in the editor when making the issue? It will be easier to troubleshoot that way.

Thank you

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.