Ctrl Shift V still doesn't work in google sheets for paste special - IV

Hi community,

When using CTRL-Shift-V to paste without formatting in Google Sheets from another window, it simply does not work.

I’ve seen several posts closed after 30 days with no solution. I’m loving the browser but this is an absolute deal breaker for me.
Does anyone have a workaround or an expectation for a solution?
I see posts going back 2017 so its not very reassuring.

Thank you!

@RenanAz,
Thank you for posting. So I do see half of the issue described – as pointed out in the previously posted topic, using Ctrl + Shift + v doesn’t work unless you are inside the selected cell.

To test and confirm this is the case, can you please try to copy something into a sheet without formatting while you are inside the selected cell (you should see the cursor blinking inside the cell) and see if the information is copied over successfully?

Hi there. Thanks for your reply.

Yes, inside one single cell, it pastes plain text (regardless of the Shift pressing).

If you need me to record a video, im totally up to it.
Pasting with Ctrl Shift V seems to randomly actually output the last thing i copied from within that sheet (but not what i really want to paste - copied from another window) Its very strange!
It’s normal for me to migrate large amounts of structured data from one sheet to another and sometimes i need it to came text only (without formulas).
I can confirm it works ok with Chrome.
Thanks!

@RenanAz,
Shields shouldn’t make any difference in this situation, but just to test, would you mind turning Shields down for sheets.google.com and see if you get different behavior at all?

Hello!
To be honest, that was the first thing i tried. Shields down + Killed the browser and relaunched with no luck :frowning:

But I have now accurately pinpointed that CTRL Shift V pastes whatever is inside the SHEET’S clipboard and NOT the system’s clipboard.
Steps to reproduce:

  1. Open one sheet in a new window
  2. Add content to it randomly
  3. Copy it
  4. Open any other webpage and copy any text / table
  5. Return to your Google sheet and attempt to paste what you just copied with CTRL Shift V
  6. Observe that it will paste what was copied in step 3.

@RenanAz,
So I see what you’re saying, but this again doesn’t seem to apply when I’m in a cell in the sheet. If I’m in a cell, it will paste whatever is in the clipboard – I’m reaching out to some team mates about this.

1 Like

Thanks @Mattches!

As i mentioned in my first reply, you are correct. However, pasting inside the cell is not so common when we are dealing daily with sheets, since you are porting things that need to also populate across columns and rows, not only individual cells. :slight_smile:

I really (really!) appreciate you following up :slight_smile:

@RenanAz If you’re able to record a video of the issue (with an audio or text-based description of the steps you’re taking), that would be greatly appreciated. Thank you!

Also, which version of Brave are you presently using?

I was having the same problem yesterday. Today when I tried Ctl-Shift-V text from a different tab, a popup suggested that I install the Google Docs Offline extension. After installing that, Ctl-Shift-V works normally.

Sure, i’ll get it done in a bit @sampson .
Version 1.15.72 Chromium: 86.0.4240.75 (Official Build) (64-bit)

@semmaow - Good idea. I will try that one.

@sampson
So, apparently i’m “too young” to upload files here haha :sweat_smile: So i have added it to my Google Drive


With audio coments and all.
Hope this helps!
I will test with the extension mentioned above.
1 Like

Excellent video, @RenanAz! One thing I’d be curious about is what you see in Windows’ global clipboard viewer. After you have copied a value, press Windows Key + V to open the clipboard viewer. Do this just before pasting to the spreadsheet too, to see if you’re getting the data from the top of the clipboard, or perhaps something a little deeper within the list.

I suspect the extension may indeed offer relief; it looks like this issue is not likely caused by anything Brave is doing. Instead, it seems as though it may be due to the fact that we don’t ship Brave with this extension baked-in, and enabled.

4 Likes

So - yep, extension solved the issue!
Strange thing is, Brave did not import that extension from my Chrome (it was the only extension it skipped) and it’s impossible to search/find it in Chrome store haha Had to find it in my Chrome install and open in the store from there.

Here is the link for any future wanderers https://chrome.google.com/webstore/detail/google-docs-offline/ghbmnnjooekpmoecnnnilnnbdlolhkhi

Might be a good idea to take a look and see why Brave skipped porting it and maybe even including this into some kind of official documentation regarding Sheets + Brave.

Thanks @sampson, @Mattches and semmaow.

5 Likes

Great job everyone :slight_smile:
Going to marked this solved – please don’t hesitate to reach out if you have any further issues.

3 Likes