Ctrl + Shift + V Doesn't Work in Google Sheets for Paste Special

In Google Sheets, I am unable to “Paste Special” (i.e. paste without formatting) by using the shortcut Ctrl + Shift + V.

There are a couple caveats to this – for when Ctrl + Shift + V will work:

  • It will paste special if my cursor is actually inside the cell (i.e. by double clicking or pressing F2).
  • It will paste special if the I copied other cells from within that spreadsheet.

So, basically, the issue is when I copy data from outside the spreadsheet. So let’s say I copy “25” from any other source (e.g. Email client, Word Document, notepad, whatever), then I go into my Google Sheet and press Ctrl + Shift + V while the destination cell is highlighted, nothing will happen.

It works fine in chrome. In Brave, I made sure there’s no extension shortcuts mapped to the Ctrl + Shift + V that might be overriding it. I also tried in incognito with no extensions on.

I’m on Windows 10 and am using Brave Version 0.64.75 Chromium: 74.0.3729.131 (Official Build) (64-bit)

1 Like

Same problem here. It’s really needed!

@bro,
Nice catch – I actually see this on both macOS and Windows 10 systems. Even stranger, I expected that something like this may have been fixed in Nightly builds by now but I see the same behavior there as well. Very strange.

I’ll file this for the team to review – thank you for bringing this to our attention!

Thanks!

And if anyone has this problem before it gets fixed, I found a workaround:

You can use the Ditto clipboard manager software (free). Once installed, go to Options > Keyboard Shortcuts, and then assign the Ctrl + Shift + V shortcut to the Text Only Paste field. FYI, I have one of the older ~2016 versions of Ditto; not sure if the same options are available on the latest version).

This topic was automatically closed after 30 days. New replies are no longer allowed.