Constant Excessive CPU Usage

Description of the issue: Brave constantly consumes between 3-10% CPU, typically averaging more than 5%
How can this issue be reproduced?

  1. Open browser
  2. Check CPU

Expected result: Minimal CPU usage (< 1% normally with brief increases from time-to-time)

Brave Version( check About Brave): Version 1.44.108 Chromium: 106.0.5249.103 (Official Build) (64-bit)

Additional Information:
Initial page has no refresh associated with it. Other pages are never selected, so are never loaded.
System is high spec with 32GB memory.
Total CPU usage (including Brave) is typically < 15% and memory < 30%.

Try this →
brave://settings/system
Turn off hardware acceleration.

Thanks. No change. I have restored the setting. Any diagnostics one could run?

@Mattches @Jarc-1107 @Kevin_cc @Alice2095 @SaltyBanana Please look into this.

@Jeronymite,
Can you tell me what extensions you have installed in the browser at this time? Additionally, would you be willing to share a screenshot of your Task manager, showing the high CPU usage?

@Mattches Thanks for your investigation.

Extensions x2: AdGuard AdBlocker and Pop up blocker for Chrome™ - Poper Blocker

Both enabled and disabled, the CPU usage is still similar. Perhaps a very marginal decrease when disabled, but not dramatic.

Task Manager screenshot attached. CPU varies between 1% and 5% at the moment, with no activity within Brave.

@Jeronymite,
This doesn’t seem too unreasonable to me, depending on the sites that you are on. You are stating that there’s no activity in Brave, but simply having the browser open is “activity” from the perspective of your system. It takes resources to keep the browser and any extensions/tabs/sites contained within, as they are all their own individual processes.

Can you test and see what happens if you open one Brave window with only one tab (open to the NTP) opened? What does the Task Manager report then?

@Mattches Thanks. I created a new profile (empty) and opened it in a new Brave browser (one only). Task Manager:

I note that I also run Firefox and Vivaldi browsers, each with similar (if not more) tabs open. Those browsers usually sit with 0-1% (max) CPU.

Separately, I also note a huge CPU usage on starting Brave (can be almost 100%) for several seconds, not seen to nearly that extent on Firefox or Vivaldi startups.

@Jeronymite,
Can you also open the in-browser task manager and share a screenshot with us? You can find this by going to Menu --> More Tools --> Task Manager.

@Mattches Thanks for your continuing investigation.


CPU varies a bit, but this is reasonably typical.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.