"confirm you're not a robot" slider pops up when searching with "site:.xyz"

Adding “site:.whatever” to my searches has been extremely useful for years to filter out unwanted domains and so on.

Now, however, I’m consistently confronted with this insulting google-esque check, which seems more like an attempt to train or reprogram my behaviour by its sheer nuisance factor, rather than a legitimate attempt at stopping bots.

I can confirm this happening to me too on brave search.
It happens using hardened firefox both on mobile and desktop, I had to switch to duckduckgo.

Hello @Lechblah , thank you for letting us know about this. What kind of device and OS do you use? Have you tried clearing cookies and cache recently? Are you using extensions? If so, try disabling some extensions and relaunch the browser. Also, let us know if you are using a VPN so we can further investigate the issue. Regards.

I tested on both Linux Mint 20.1 for desktop and EMUI 5 (Android 7.0).

No VPN enabled, just custom DNS (quad9) and a very fingerprint resistant Firefox with harkenfox-like setup and uBlock Origin, both on mobile and desktop. I don’t use chromium stuff so I cannot confirm the consistency of this issue within other browsers.

After a 30-minutes testing I can say that the verification page appears around 70% of the times (all browsing data, cookie/cache reset before each attempt).

Other search queries are blocked by the same page if I don’t confirm being human first, but resetting browsing data allows bypassing the captcha.