When using search.brave.com (in Firefox), it gives me the robot captcha almost every time

Description of the issue:
When using search.brave.com, it gives me the “Confirm you’re not a robot” captcha almost every time I do any search about anything.

Brave Version (check About Brave):
None, I’m using Firefox 102.10.0esr

Operating System:
Windows 10 Pro 22H2 19045.2846

  1. Do you use any kind of VPN or proxy? Captcha mostly got triggered because of VPN or proxy enabled. Temporarily disable them to fix the issue.

  2. If the answer above didn’t fix your issue, it could be because of masking user agent. You could use Firefox masking as a Chrome. That could be a issue too

  3. Is it works just fine in other browser? (Brave or Chrome)

No VPN, proxy, or user agent masking. I didn’t try it in other browsers.

I hadn’t tried it in a while, but I just did a few searches and the captcha seems to have relaxed now. No idea why it was so needy before.

Thanks for the suggestions!