Clearing History (all time) hangs in endless loop

Hi,

Using Brave 0.63.48 Chromium: 74.0.3729.108 (Official Build) (64-bit) on macOS 10.14.4 with Retina MacBook Pro 15" - mid-2015

I’m seeing an endless loop that only stops when I close the settings tab in “history” when attempting to clear the history in my brave browser.

I’ve got a screen recording documenting my issue.

1 Like

@sffcloud,
Thanks for reaching out. A couple questions:

  1. Does it clear the history, regardless of hang?
  2. If you have the history tab closed the process doesn’t hang – is that correct?
1 Like

I receive the same issue at times. sometimes it will continue to loop, but clear the history and other times it doesn’t.

This happens to me as well sometimes. It clears the history but it’s hung and doesn’t dismiss the dialog on that tab or window.

I should have made clear; yes it does clear the browsers’ history. And you’re right, I can’t reproduce the hanging if the history tab isn’t open.

1 Like

I too have this issue.It hangs but also clears the history.
I just sawe yr question and thought it might be informative to answer.
Cheers.

Hi, I was experiencing a similar issue. It’s just hangs without clearing the history and the cancel button does not work. Seems a bit random when it happens. I’ve removed my 2 extensions, unspoiler and presearch, and now it works fine. Thank you

Thank you everyone for reporting.
My suspicion is that when the history tab is open, its open in its own tab and, further, its own process (just like all tabs). When you clear the browser history, the dialogue may have a conflict dismissing itself while both processes are open.

I’ve reached out to some team members but I’ll likely end up filing and issue for it for the devs to review.

@Mattches @sffcloud and others.
It seems this topic is also running in a thread which was posted after this one?

So :blush:
with my Brave, on my set up,

when I have gone this route, and then exited Brave, thereafter the browser WILL NOT come up again. My Lion glows, then stops glowing and Brave will not come up.
I have to restart the desktop in order for Brave to be responsive again.
So I have absolutely ceased and desisted from using this route to deal with cleaning.
Ref :


:sunglasses:
:leaves:
PS: I think the hanging also happened with me too, but I sort of didn’t log that it was happening at the time, because my focus was only on basic navigation in the first place.

@Dryad,
Does this happen for any timeframe selected or only for clearing data from “All time”?

1 Like

I’ve run into this issue a few times over the past week and again this morning.

Happens even if I don’t have the history window open.

It happens for all time frames (All Time, Last 4 Weeks, 7 days, 24 hours).

Happens when all my extensions are turned off.

I relaunched brave, and now it works. Maybe I was behind a version? Not sure…

2 Likes

@Mattches
Apologies, I didn’t pick up this message to me before now.
It was, I think, at the time when I noticed it,

I have also had that when I exit Brave using the white ‘x’ in the red block in the left hand, top corner, Brave wouldn’t come up again.
So now when I exit, I use ‘exit’ in the ‘hamburger’ and that seems to mean that I can bring up Brave again without having to restart the desktop. [Win7]
I use the browser in a very basic way - I think the terminology would be that I don’t have any ‘extensions’ - I’m very manual with passwords, I don’t get ‘ad-ons’ from ‘chrome’, [beginner in these matters] so I think I’m less prone to ‘bugs’ but my Brave does appear to be a bit 'tetchy. I’ll try and watch vigilantly again to make specific notes.
:leaves:

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.