Certificate problem with youtube

**Description of the issue: Cannot open youtube
How can this issue be reproduced?

I always get the certificate is not secure problem and it does not happen with any other websites, I also cannot click advanced and continue. I tried to switch my dns to opendns and nothing happened.

Expected result:

Brave Version( check About Brave): [
1.19.88 Chromium: 88.0.4324.96

Additional Information:


Which certificate error are you getting (screenshot)? also confirm your date/time is also correct.

It is solved after restarting the computer and I have no idea why.

The certificate was DigiCert Global Root CA-1 or something like that from YouTube, I have downloaded the license manually and imported it to the trustworthy certificate part in the browser, after the restart, it was ok but I don’t think it was because of my doing, perhaps brave needs a restart before working properly when you install it the first time, or at least it happens sometimes.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.