Can't set Brave to be my default browser on Ubuntu 22.04

Description of the issue:
Brave browser isn’t able to set itself as default browser.

Steps to Reproduce (add as many as necessary):
Unknown, this is a fresh install of Ubuntu and Brave.

Actual Result (gifs and screenshots are welcome!):
If I execute the commands from the documentation on how to set Brave as default (in this order):

me@mymachine:~$ xdg-settings get default-web-browser
me@mymachine:~$ xdg-settings set default-web-browser brave-browser-beta.desktop
me@mymachine:~$ xdg-settings get default-web-browser
me@mymachine:~$ xdg-mime query default x-scheme-handler/http
me@mymachine:~$ xdg-mime query default x-scheme-handler/https
me@mymachine:~$ ls -l /etc/alternatives/x-www-browser
ls: cannot access ‘/etc/alternatives/x-www-browser’: No such file or directory
me@mymachine:~$ ls -l /etc/alternatives/gnome-www-browser
ls: cannot access ‘/etc/alternatives/gnome-www-browser’: No such file or directory

Note, I don’t even have Firefox installed.


Also, when I click “Make default” in Brave’s settings to make it my default browser, nothing happens. Next time I launch Brave I get the banner that Brave isn’t my default browser again. Also clicking on the banner to make Brave default does nothing, except to hide the banner.

Expected result:
Brave should become my default browser.

Reproduces how often:
Every time.

Operating System and Brave Version(See the About Brave page in the main menu):
OS: Ubuntu 22.04
Brave: Version 1.46.134 Chromium: 108.0.5359.94 (Official Build) (64-bit)

Additional Information:

1 Like

Hello there @reasonsharp could you please try installing either Brave Beta or Nightly to see if you can set them as default browser?

Let me know if you are able to set it as default.

1 Like

Hi, @Kevin_cc !
Installing Brave Beta
Version 1.46.138 Chromium: 108.0.5359.94 (Official Build) (64-bit)
worked and it was able to set itself as default.
On first run after each system restart, it now requests I type in my password (I configured to start my system without asking for credentials). Is this normal behavior?

1 Like

Hi again @reasonsharp. Are you prompted to enter your system password every time you open Brave? Please provide me with more details about this message you get in order to further assist you.

Hello, @Kevin_cc !
I can’t take the screenshot of the message I get, but it says this:
“Authentication required
The login keyring did not get unlocked when you logged into your computer.”
Then I need to put in my password and click “Unlock” to open the browser.
This doesn’t happen every time I open Brave, only once after a system restart. If I close Brave afterwards it will open without the password prompt, but will require it again if I restart the system.

1 Like

@reasonsharp can you try disabling and then enabling the option to type in the password instead to ask for credentials you’ve set on your computer to see if this solves the issue?

Let me know if that works.

I have the same problem (Ubuntu 22.04) : can’t set Brave as default browser.
Unlike reasonsharp, Firefox is installed (by default with Ubuntu installation). I have the banner asking for set it as default browser each time I open it after a restart.
I’m wondering if it is not due to “snap”, as all apps are installed from it in Ubuntu 22.04.

1 Like

Did you try installing the Beta version of Brave to see if you are able set it as default on your Ubuntu version?

Let me know if that works.

I had the same default browser error problem and when I tried uninstalling and reinstalling the Snap Brave verision, I ended up with what appeared in System Monitor as two parallel running instances of Brave. Ultimately, I looked at the install page at the Brave website-

It reads:


“You can find Brave in the Snapcraft Store, but while it is maintained by Brave Software, it is not yet working as well as our official packages. We currently recommend that users who are able to use our official package repositories do so instead of using the Snap.”

I uninstalled the Snap version of Brave and installed Brave using the Release Channel Installation commands for Ubuntu at the top of the page and now it works without any problems. This doesn’t answer why the Snap version was giving me trouble, but the message is gone now.

1 Like

Maybe there was an issue with the files included on the package installed from Snapcraft that was not present on the release channel, but if you encounter this same issue again please let us know.


Open a terminal and execute this command:

xdg-settings set default-web-browser brave_brave.desktop

I managed to set the Snap version of Brave default app after it wasn’t showed in the browsers list.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.