Brave Default Browser

A new problem has started that I never had before. Brave is suddenly saying it is not my default browser even though in all possible settings it IS the default browser.
I just spent an age trying to correct this, but EVERY time I start brave it tells me it’s not my default browser and to ‘click here’ to make it the default browser.

I’ve set it in Linux, and sure enough if I select a URL from an external app it starts Brave but the very first thing Brave does is tell me it’s NOT the default browser!

I’ve set it in the Brave settings themselves. But there’s no way of knowing if it did anything.

I’ve deleted cache and cookies etc. which is a pain as I’ll now have to build them back up to what I’m sued to. That didn’t work either…

Where is Brave getting the idea that it’s not the default browser from?
It’s not from it’s own settings and it’s not from the Linux system’s settings.

H E L P !

Is no one seeing this, or does no one have a clue?
I can’t see a count of how many have read it?

Wow… almost a month on the forum and this question has no responses?
Does anyone know of any other Brave forums where people actually answer your queries?
Are there actually any people using this forum at all?

1 Like

I solved it myself…
The following terminal command solved the problem:-
xdg-settings set default-web-browser brave-browser.desktop

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.