Cant execute any downloaded .exe files anymore

Windows 11 Pro x64 23H2 22631.3374 [Version 1.64.113 Chromium: 123.0.6312.86 (Official Build) (64-Bit)]

cant execute any downloaded .exe files anymore.
what i did:

  1. re-installed brave browser
  2. reset settings
    files to test:
  3. https://download.xnview.com/XnViewMP-win-x64.exe
  4. https://github.com/c0re100/qBittorrent-Enhanced-Edition/releases/download/release-4.6.4.10/qbittorrent_enhanced_4.6.4.10_qt6_x64_setup.exe
  5. https://www.bittorrent.com/downloads/complete/

behaviuor:
downloaded the files without any issue.
then i tried to execute them via explorer.exe, nothing happened…

expected behaviour: install my sh*t

tried same with current edge browser:
works perfectly!

what to do?
thanks

p.s. may my browser be infected somehow?

Browsers does not install .exe files on windows, You May have an Windows issue, Antivirus or UAC or Smartscreen Might be Blocking it.

Strange, because Edge Browser installs without any issue…

Record a video on Loom and Share it here as it’s hard to believe while you say something works on Edge but not on Brave… Brave and Edge both uses Chromium and i dont understand what you mean by installing .exe inside a browser or using browser to install .exe. Sharing a video will help me to Gain Clarity.

agree, it’s probably your AV or Smartscreen blocking exes. If you can see them in explorer, they should execute.

Hi,

Ensure that Brave’s settings https://search.brave.com/settings are not blocking the execution of downloaded files. Look for any security or privacy settings that might be preventing the files from running and adjust them accordingly.

This may help you.

Thanks
Floating Ball Valves

i know my english is not the best, but what can be misunderstood, if i say that:
all the files mentioned above, were downloaded corrupt somehow, because they´re not executable anymore.
when i try the same with Edge browser, i can execute those files in explorer or browser to install them!
that happens to all downloaded executable files with Brave!

Record the Behavior in Loom and show comparison So i can understand What’s your Problem with Brave browser.

https://chrome.google.com/webstore/detail/loom-–-screen-recorder-sc/liecbddmkiiihnedobmlmillhodjkdmb

this behaviour happens not only to brave browser, but to all of my other installed browsers, chrome, firefox, waterfox…
as an workaround temp solution i disabled the reliability-based protection in the windows security

only m$ edge browser was able to execute my downloaded .exe files -.- even file explorer cant run the dl .exe files from other browsers, except the edge ones…

I don’t do Windows, but I have a couple of generic ideas.

When you download an executable file (from somewhere you trust!!), the first thing to check is that your copy is set with permission to execute. That often gets turned off in downloaded files as a safety precaution.

Sometimes, files on servers are listed along with checksums. If a checksum is available, you can recalculate the checksum of the file you downloaded. If it’s not the same as the one on the website, etc., then your copy is corrupted and should not be used as it is either a broken copy or has been modified somehow, possibly by malware.