Autoplay blocking too 'strong'

Repeating Autoplay TOO 'strong'.

Continued issue. Responding twice in a manner that ignores the actual issue (clearly does NOT retrace the actual repro steps - even while having MANY different ones), and subsequently simply closing ‘due to inactivity’ (what more input do you want from me?!?!??) is just lazy.

Might not be the biggest problem / low priority. Still annoying as HECK though, and, as said, this was already an issue ever since Autoplay blockage was ‘fixed’ compared to when it was not blockcing aggressively enough, back in 2020.

Also, AGAIN: is no one actually following up on actual bug reports (on gibhub) i.e. in this case on https://github.com/brave/brave-browser/issues/18369, like, ever??

Love <3 Brave, seriously, but COME ON guys, get ON this (sort of stuff) please!

Repeating original post:

Description

With Autoplay set to ‘blocked’, many (yet not all) sites are

  1. not even playing any media (audio/video) based on user input, at least not properly, i.e. when the user clicks ‘Play’, it is simply ignored (or cancelled).
  2. also blocked from ‘go to next file’, in playlists.

Steps to Reproduce

EDIT: added telling example on radiorecord( .ru).

  1. Ignoring user input:
    A. Go to an affected site (YT for example is NOT affected by this), for example radio, or vimeo. Twitch is another funky example, as is radiorecord .
    B. Click ‘Play’. In the case of radiorecord , click another genre while another one is still playing.
    C. ISSUE: the content does not play (not at all i.e. is fully unresponsive or loads indefinitely, or might not play until user clicks pause and then play once again; either way, content is somehow ‘overblocked’ or at least not ‘cleverly blocked’). On Twitch, the sound gets disabled and re-engaging it stops video playback. On radiorecord , the second genre refuses to play (unless the first one is PAUSED!!); the intitial genre does not trigger the Autoplay ‘Blocked’ setting, at all, but the switch to another genre does trigger it, and incorrectly ignores user input (‘Play’).
  2. Playlists
    A. Go to (an affected?) site with playlists, e.g. a Youtube or bandcamp (com).
    B. Open a Playlist (site with multiple ‘pre-loaded’ pieces of content ordered for continuous playback).
    C. Click Play.
    D. ISSUE: insofar part 1 of this issue is not triggered, the file plays, but the next one does not. Having to click Play for every part of a playlist defeats its purpose!

Actual result:

All scenarios: (immediate) playback is blocked (see ‘ISSUE’ under repro steps for details).

Expected result:

  1. Playback should work
  2. ‘Automatic’ playback in playlist should potentially be allowed (probably more a feature request than a bug - maybe split?)

Reproduces how often:

100% - depending on specific site content playback technologies, and how the Brave protocols (do not) handle these, exactly.

Brave version

Version 1.29.81 Chromium: 93.0.4577.82 (Official Build) (64-bit)
Win10 Home 19042.1237

Version/Channel Information:

Other Additional Information:

No issue with Autoplay off.
Shields do not seem to make a (bug) difference.