Cannot change spell-check (firewall?)

Description of the issue: Cannot update spell-check language, error is thrown (see below)
How can this issue be reproduced?

  1. Open settings
  2. Try to add language as spell-check (in this case - “English (Australia)”
  3. …Click it

Expected result: Spell-check would change to my language/dialect as selected

Brave Version: LATEST, Version 1.10.95 Chromium: 83.0.4103.106 (Official Build) (64-bit)

This error is thrown:
“Spell check dictionary download failed. Please check with your network administrator to make sure that the firewall is not blocking downloads from Brave Software servers.”

@Wolfenstein98k, Welcome to Community!
Are you using a VPN or any anti-virus software?


No VPN active at the time, and I only use the standard Windows Defender antivirus.

Using a typical Acer laptop, typical hardware, typical software, nothing that isn’t generic or standard.

EDIT: Note that I posted this in the Reddit on the same day and several users experience the same issue:

Can you try disabling Windows Defender and re-adding the language?

Confirmed - issue exists no matter what is turned off (including every option) in Windows Defender. No other firewall software is installed. Completely stock PC.

Have you tried re-installing? If not, can you try and let me know the results?

I have an update for everyone here - the team is aware and is working to resolve the issue.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.