Cannot access KickStarter in Brave

Browser Version: 1.25.68 Chromium: 91.0.4472.77 (Official Build) (64-bit)
Add-Ons/Extensions: None
OS: Windows 7 Home Premium 64-bit
ISSUE: Back in January I made the move away from Pale Moon (my previous browser) to Brave due to PM being excessively slow and prone to locking up doing basic things like checking e-mail. I have been mostly happy with Brave, but there is one quirk which irritates me to no end. I am fairly active on KickStarter, as I have three projects backed that I receive updates on and am helping a friend manage another. Every time I try to visit the site, I receive a notification that my connection is not private and Brave refuses to load it. (This happens on occasion with eBay, Amazon and a few others, but Brave will usually allow me to click a button to get past it to a mostly-functioning website with a few pictures missing.) I have had to re-install Pale Moon JUST to be able to use KickStarter and it gets quite tiresome since that browser takes a ffull ten minutes to load the page. I have tried with Shields Down, I am not running extensions, it will not work in a Private Window, no settings I have changed (and I cannot remember all of them that I have tried) have remedied the issue. Is there anyone that can tell me what’s going wrong so I can access this one bloody website?

1 Like

Thank you for reaching out to us. So I was able to visit on my end without any issue (Shields up, everything at default). Can you try clearing cache/site data for Kickstarter?

  1. Attempt to visit
  2. Click the Lock icon in the address bar then Site settings
  3. From here, click Clear data

The Private window test you ran should have essentially done this, but I’m still interested to see whether or not this has any effect.

Followed your instructions to the letter. Same end result. I am now also getting a “Your clock is ahead” error when rying to visit Amazon, the Funimation website, the website for my cable company etc. Basically any website I use for shopping or paying my bills is unable to be accessed period.

Can you check your date on the computer? is set correctly to 2021? @KamenRiderGumo

@fanboynz It is correctly set, yes.

If you properly shutdown the PC, (wait 40 secs) and then restart the PC. Does the date/time still match the current?

The clock remains the same.

Do you have any anti-virus software running at this time?

@Mattches Nope. I have never used an anti-virus in my life. If there’s a way to just disable this “feature” entirely I would gladly use it, because otherwise I am going to have to switch to a completely new browser - which means either Chrome or Firefox and I REALLY don’t want to use either.

What does the cert say? Heres mine: Also, are you using a secure dns by any chance?

@fanboynz I’m definitely getting different results than you are.

(Also, now Hulu will no longer work - I cannot log in because I can’t get past the reCaptcha. I answer it correctly, then hit the Log In button and the Captcha just resets to an unchecked box.)

Following through with this: Does the issues show up in Chrome also?

@fanboynz Had to install Chrome (never used it before) to check. Yes, I get the same message about an invalid certificate.

Okay - I seem to have rsolved the issue. I needed to do a Windows Update, but searching for updates from the control panel simply would not work and I would get an “80072efe” error. After pulling off some Google-fu, I found that I had to download and manually install the update from Micosoft’s website - a file named “Windows6.1-KB3138612-x64.msu”. Once that was installed and my system rebooted, I was able to download the 171 updates that were waiting and now all of the websites I was having trouble with now function as they should. I think we can consider this one closed. Thanks to everyone who tried to help - you taught me things I didn’t even know I could do and while I was trying to check on the things you all mentioned was when I had the idea to try the Windows update. I’m not computer illiterate by any means, though my primary expertise starts at DOS 6.0 and peaks at Windows 98SE, and sometimes I just need the right nudge at the right time to stumble onto an answer.

1 Like

Excellent detective work. I’m glad you were able to resolve the issue and continue using Brave :slight_smile: