Can’t watch purchased YouTube movies or tv shows in Brave browser

Hello. I downloaded and have been trying the Brave browser on my iOS devices (iPad mini).

When I log in to YouTube on the Brave browser I noticed that regular YouTube uploads will play just fine for me.

However, in the Brave browser, I cannot watch YouTube movies or tv shows I purchased.

When I go to the area on YouTube where my movie and tv purchases are, and try to watch one of them, the message on the video says “Your browser cannot play this video.”

Any way to rectify this? Is there sometime I need to check or uncheck in the Brave browser settings?

Thanks.

Thank you. I’m on my iPad and don’t have any extensions in the Brave browser. I’m been doing some reading up on this error message that people get sometimes when they are trying to watch their YouTube movie and tv purchases. From some of the stuff I’ve been reading it might be an issue with a “widevine” extension. I’ve been instructions on how to ensure Widevine is enabled in some desktop browsers, but NOT any mobile browser like the Brave browser I have on my iPad.

Thoughts?

On browser u must activate DRM option (Widevine) in settings, it’s the option that turn on the lecture and decrypt of protected content… idk why Brave turn off it automatically when it’s fresh start, it must be able… on Phone android and ios don’t work and Brave seems don’t want work on it, u can check brave://flags and force widevine/drm to be enable too

Could you test in Firefox for IOS? Does it work there?

Thank you so much. I appreciate your help. I typed in brave://flags and it seemed to take me to a search engine where different results came up. I honestly feel like I may just have to request to Brave that they consider possibly updating their mobile browser and allowing activation of widevine in the mobile browser.

1 Like

Thank you for your reply. And yes, unfortunately, the same issue is in Firefox. No issues with regular YouTube uploads. It’s with my purchased movies and tv shows where I receive that message that my browser can’t play the video.

Edited: I checked and on iOS and like Android… Widevine/DRM support doesn’t exist, another user told there are an old versión that work correctly Widevine but it’s just for Android, maybe an old versión for iOS could work too

Does Chrome for IOS work @freelancerjourn ? Brave for IOS was orginally forked from Firefox IOS source btw.

@freelancerjourn ,

With Brave Browser running, in a New Window, go to brave://settings/clearBrowserData

Examine all the settings for all three tabs: Basic / Advanced / On exit

Use among those settings, what you need for clearing any cookies, data, etc. – what you believe necessary, at the moment.

Next, consider, and adjust the settings for all three tabs, as you think best fit your need and browser operations.

Using a browser > Developer Tools > Network . . . tool, I identified some of the following as sources, and others as possible, for some cookies and javascripts when visiting YouTube:

With Brave Browser running, in a New Window, go to brave://settings/cookies

Scroll down that settings page, to Sites that can always use cookies

Click the Add button

Enter accounts.google.com as the site . . . but do not Enable

  • Current Private session only
  • Including third-party cookies on this site

Click the Add button

Next, repeat those steps for the remaining items in the above list.

NOTE: All of those entries, are potential sources of cookies (not the cookies themselves).

But REMEMBER, that your cookies settings may or may not come into play, affecting the fate of your entries (sources for cookies) . . . depending on what arrangement you determined (above, at brave://settings/clearBrowserData), for the moment and for longer-term.

With some experience, you will learn how to adjust your cookies settings, and add or remove, the sources for cookies. Your carefully written notes, will help you.

YOU are the troubleshooter.

With Brave Browser running, in a New Window, go to brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter accounts.google.com as the site . . . but do not Enable

  • Current Private session only

Click the Add button

Next, repeat those steps for the remaining items in the above list.

The javascript settings for Allowed to use javascript will operate, whether or not you have Brave Browser Shields “UP” or “DOWN”.

There are other Google sources, that were not found in the Developer Tools > Network . . . tool, YouTube session. The following were found, when monitoring a Google Meet website session:

From among that list, you might want to add to your Allowed cookies and Allowed javascripts – for YouTube purposes:

They might come into play.

Thank you for this. I appreciate it. Question: is this for the desktop Brave browser? Because I’m running the mobile Brave browser on my iPad. And I don’t have those settings. In my location bar I went to the first URL you recommended. In the location bar I typed in the URL you indicated, and it took me to a search engine, not any type of settings.

Thank you. And unfortunately, no, Chrome for iOS doesn’t work either. I receive the same “your browser can’t play this video” error message.

@freelancerjourn ,

Oops. That was for the Mac computer. Changing mind mode to iOS . . .

Try . . . GLOBAL DEFAULTS:

Brave Browser > Settings > Brave Shields & Privacy > BRAVE SHIELDS GLOBAL DEFAULTS:

Block Cross-Site Trackers Enabled
Upgrade Connections to HTTPS Disabled
Block Phishing and Malware Enabled
Block Scripts Disabled
Block all Cookies Disabled
Block fingerprinting Enabled

Brave Browser > Settings > Brave Shields & Privacy > OTHER PRIVACY SETTINGS:

Private Browsing Only Enabled
Block Popups Enabled
Allow universal links to open in external apps Disabled
Block dangerous sites Disabled

Whatever changes you make, test the position of the Private Browsing Only switch, and leave the following two, Disabled

Block Scripts
Block all Cookies

. . . would be my recommendation, for starters.

And AFTER you set the GLOBAL DEFAULTS, then visit the YouTube website and double-check the [Lion icon] Shields pop-down:

The Shields pop-down has a toggle-arrow, to be selected in order to get a view of the “Advanced Controls”. Double-check:

Block Cross-Site Trackers is Enabled
Upgrade connections to HTTPS Disabled
Block Phishing is Enabled
Block Scripts is Disabled
Block fingerprinting is Enabled

After previously testing the switch position for Private Browsing Only – then test the Block fingerprinting switch (for each position of the Private Browsing Only switch).

Given other mobile browsers can’t do this, Its probably either a ios and/or mobile limitation. Would be interesting to see if this issue occured in Android

try enabling the DRM via brave://settings/?search=drm

@LME ,

Currently, Brave URL’s do not function for Brave Browser iOS – no field of entry.

@michal Any idea on all of this?

Looks like WKWebView limitation, if Chrome and FF can’t make it work, slim chance Brave is able to

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.