Bug: Videos autoplay in browser when receiving facetime/call on mac

Description

Everytime i recieve a phonecall/facetime on my mac (via my iphone), videos will start playing in browser. For example, I have a udacity course tab open (youtube video embedded on the page), and I’ll recieve a call. As soon as my computer rings, the youtube video will begin to autoplay.

Steps to Reproduce

  1. Recieve call on iPhone
  2. Call is picked up by Mac
  3. Video on brave browswer unpauses and begins to play

Expected result:

Video should not unpause and begin to play. Video should remain paused/not played

Brave Version

Version 0.63.55 Chromium: 74.0.3729.131 (Official Build) (64-bit)

Reproducible on current live release:

yes

1 Like

cc @Mattches @gsarvadnya for assistance here.

1 Like

@jps394,
That is a very strange bug! Thank you for bringing it to our attention. Out of curiosity, do you have autoplay set to Blocked on mobile and/or Desktop?

1 Like

Within brave browser, autoplay is not currently blocked.

I can change it to blocked though to see if that affects this?

Definitely try that – at least for any sites confirmed initiate video playback when a call is received.

Will do - will let you know if the problem persists (if I forget to respond, it’s likely because the problem hasn’t come up as a result of this).

Thank you

1 Like

I am facing this issue as well.But this isnt on the Brave browser but on Chrome 74.0.3729.157 (Official Build) (64-bit),

I am getting this very same behavior as well on a Mac and Version 0.64.76 Chromium: 74.0.3729.157 (Official Build) (64-bit). Also having same issue in Chrome but not with Safari after some testing.

Wondering if this is a Chromium related issue perhaps?

This is a Chromium issue imho not specific to Brave. I’ve been having the same problem for at least a few weeks now. I’ve noticed this also on my iPad when a browser window has a video specifically YouTube in a tab it will autoplay. It may also do this to other pages with video just in my case I’ve only had YouTube videos in tabs.

macOS Mojave v10.14.4
Chrome: Version 74.0.3729.169 (Official Build) (64-bit)
Brave: Version 0.64.76 Chromium: 74.0.3729.157 (Official Build) (64-bit)

Super annoying and no fix yet I just finally got annoyed enough to look for a solution today. If I find one I’ll write back.

Edit: This did not end up consistently resolving the issue.

Doing this fixed the issue for me and I tested it by having someone call me both before and after the fix.

  1. Copy / Paste this link in your browser URL in Chrome and/or Brave
    chrome://flags/#autoplay-policy
  • I made this change to both my Chrome and Brave browsers
  1. Click the dropdown next to Autoplay policy and change it from “Default” to “Document user activation is required”

  2. Click the blue Relaunch Now button in lower right

  • This will restart your browser

This should fix the issue.

1 Like

@jps394, @ejm201 @jambo116
Can you please test @conzone’s method and see if it resolves the problem for you?

Unfortunately my attempt to implement @conzone solution did not work for me :frowning: I really haven’t invested much time in troubleshooting I will dig a little deeper as time allows.

@ejm201 Darn. Sorry guys it seems to have also been a fluke on my machine that I thought it worked earlier for me. I went back and retested both browsers going back to original settings and then with my suggested changed I tested earlier and I continued to have the same autoplay issue.

This is a bug in Chrome that the Chromium team is now aware of and addressing. For more details or to follow the fix through its release, see https://bugs.chromium.org/p/chromium/issues/detail?id=961308.