Autoplay Does Not Block Videos


Description of the issue:
Setting autoplay to ‘Block’ in site settings (for some sites) does not take effect. The result is that videos autoplay with sound.

How can this issue be reproduced?

  1. Open Brave browser.
  2. Visit this URL: https://time.com/5928583/elizebeth-friedman-codebreaker/
  3. Adjust site-settings. From the ‘Auto-Play’ option, ensure this is set to ‘Block’.
  4. Reload (and to be sure restart browser).

Expected result:
The offending video should not play at all.

Brave Version( check About Brave):
I am using Brave v 1.17.73

Additional Information:
I’m using Mac High Sierra.