Apple IOS Brave App Video Playback bug

Description of the issue:

Issue 1:Video Playback issue.

The Brave iOS App no longer streams videos well. Specifically, Streaming any videos sometimes results in a sudden lag despite the network connection being good with no issues. If you hit pause and leave the browser to go to another app, sometimes the video will keep playing. Other playback issues include that when a phone call comes in and you are playing a youtube video while connected to a bluetooth device, the video will keep playing. Resulting in the person having to hang up the call, exit out of Brave completely and then have the person either call back or you call them back.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Play any video on a website.

iOS -16.1.1. Brave Version 1.45.1 (22.11.17.19)

That issue seems to be more of IOS. I guess I read somewhere about this being iOS, not Brave.

Not sure how that is more of an iOS issue since I do not get that problem when I use Firefox or Safari on iOS.

Hello @Zinthos

Thank you for reaching out, we appreciate the details. Please try to open a new page using private mode or guest mode.

In order to get a Private window, you’d have to hit the tabs button (like you’re trying to switch tabs, it’s a little box with a number showing how many tabs open). Then while it’s showing all open tabs, you’ll see the Private button to click on. From there

Let me know if that works and have a great day!

Hey there @Alice2095. I just wanted to let you know that the setting is not there on Mobile devices. In order to get a Private window, you’d have to hit the tabs button (like you’re trying to switch tabs, it’s a little box with a number showing how many tabs open). Then while it’s showing all open tabs, you’ll see the Private button to click on. From there, it switches to Private mode with its own set of tabs. To switch back, need to repeat the process.

That said, since iOS and Android can’t use extensions/add-ons with Brave, the likelihood of seeing any positive changes from Private is kind of slim. Also, for some reason, we don’t get Profiles on Mobile like we do on Desktop.


@Zinthos I’m going to focus on you talking of the lag for the moment. Do me a favor and answer the following:

  • Is this happening on all sites or just specific? (if particular site, please share which)

  • Have you tried with Shields off? Curious if it will make a difference.

  • Does this happen regardless of whether you’re on wi-fi or cell data?

  • Have you enabled any filters under Content Filtering which is found in Settings → Brave Shields & Privacy → Content Filtering? If not, please go there and activate Fanboy Annoyances List and uBlock Annoyances List. These can sometimes help with performance, especially if any lags or other issues come from ads or other content on the pages.


As to it playing in the background, you’ll want to navigate within Brave to Settings and then make sure the toggle for Enable Background Audio is turned off. This is a setting that otherwise allows things like videos to keep playing so you can listen uninterrupted while doing other tasks. If you do leave this on, you’ll notice in your Notifications (pull down from top of your screen, where all your notifications normally show) will be a little thing showing what’s playing and will have a pause/play button. So you can pause it to stop it from playing.

I might be wrong about that in terms of it happening with Bluetooth, but I’m assuming that’s what it is.

@Saoiray Noted. Thank you so much! :wave:

Hello @Saoiray & Alice2095.

Thank you for the assistance with this.

Here are the answers:

  • Is this happening on all sites or just specific? (if particular site, please share which)
    I am seeing this on all websites. Youtube is one example. I also see this on embedded videos that are placed in news articles. For example, a news article could have an embedded video that came from twitter or Youtube and it may lag a bit. However, if you go directly to to the twitter or Youtube video it may lag less. Also, if you try to do full screen mode with the embedded youtube video, it will tell you that your browser does not support that feature.

  • Have you tried with Shields off? Curious if it will make a difference.

I have not tried it with the shields off since a lot of videos have ads in them.

  • Does this happen regardless of whether you’re on wi-fi or cell data?

Yes, it happens either on Wi-Fi or on cell data.

  • Have you enabled any filters

Yes. Content Filters: Easylist-Cookie List, Fanboy Social List and Mobile Notifications list. I just switched it to the ones that you suggested and turned off the Enable Background Audio setting and will see what it does. Thank you for the assistance!

@Saoiray

Hello sir, Spam bot is still holding up my initial response to you and Alice. Despite that, after making adjustments to the Content filters that you suggested, I am happy to report that the mobile web browser is much faster overall, videos load quicker, and do not have lag issues anymore. Thank you so much for the assistance and have a great Thanksgiving!

2 Likes