Bug -site settings won't hold, they reset after I close browser

On Ubuntu 22 LInux, Brave v1.57 - this bug has existed a while now. Open up a browser. Go to YouTube.com - click the lock in the address bar - then site settings. Change AutoPlay from “allow” to “block”. Now close browser.

Open browser again. Go to Youtube again. Click the settings again. You will notice that AutoPlay is set back to “allow”. Furthermore, any extentions I add also do not work to stop AutoPlay.

This annoys me so much I had to switch back to Firefox as my main browser. It works perfect in Firefox to block AutoPlay. Any suggestions?

1 Like

Could somebody try this and confirm the same bug on their system?

I would greatly appreciate it if another Linux user could test and see if this bug occurs with Brave browser on their system. Thanks

@usernname100234 Hey, sorry been going without a response. Somehow this even slipped past me despite how often I’m constantly here to help people. I don’t have Linux, so can’t test on that. I did check on Windows and the settings remain.

I will ask, do you have anything set to clear cookies or site data when you exit Brave? Such as the option at brave://settings/cookies or the On Exit portion of brave://settings/clearBrowserData?



And if not, then other thing I’d ask is if you might have any extensions or programs like CCleaner, Avast Cleaner, etc that you use to “clean” your device?

Also, can you confirm which version of Brave you’re using now (actual version number, don’t say “latest”) and if it’s still an ongoing issue?

hello, have you fix it?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.