Browser not picking up policies set in the Windows registry

Description of the issue:
I have “AuthNegotiateDelegateWhitelist” and “AuthServerWhitelist” REG_SZ entries in HKLM/SOFTWARE/Policies/Chromium and the Brave browser is not recognizing them. I am able to successfully set the --auth-negotiate-delegate-whitelist and --auth-server-whitelist flags though.
I’ve installed Chromium to see if I was just crazy, but it is able to pick up the entries and properly set the policies. I can go to brave://policy and it shows as empty, while going to chrome://policy in Chromium will show both policy entries.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Fresh install of Brave v1.4.95
  2. Add “AuthNegotiateDelegateWhitelist” and “AuthServerWhitelist” entries to HKLM/SOFTWARE/Policies/Chromium
  3. If Brave is running, restart application.
  4. Go to brave://policy

Actual Result (gifs and screenshots are welcome!):
Policy entries are not being recognized at application start

Result is that Kerberos auth isn’t available unless startup flags are set in application shortcut.

Expected result:
Screenshot added from Chromium (dev build 82.0.4072.0) to show expected entries

Reproduces how often:

Operating System and Brave Version(See the About Brave page in the main menu):
Brave: v1.4.95/Chromium: 80.0.3987.122
Windows 10: v1703 (OS Build 15063.1387) (Joined to AD realm)

Additional Information:
I’ve rebooted the computer to see if there were any lingering processes just not letting go of the config, but I’m still in the same empty state as I was prior to the restart.
I’ve tried finding an installer for the specific Chromium build of 80.0.3987.122 but only seem to be able to pull 80.0.3987.0 (Have tried several downloads from the commit position past 722274).
chrome://policy properly showed the configured registry policies from the 80.0.3987.0 builds that I tried.
I should probably add that I did try running the browser as “administrator” and had the same result.

After the update to v1.4x, the correct registry path is no longer the same as Chrome/chromium. You should be looking in 1.


Added entries to the path supplied. Was picked RIGHT up after clicking the “Reload Policies” button under brave://policy. Was this change documented anywhere? I tried looking at the release notes and the support site but was unable to find anything earlier.


I quite literally just updated the Help Center to include group policy documentation yesterday. Should be viewable now: