Browser Extensions Corrupted Requiring Repair

Recently extensions are requiring repairs. . . A couple of times all of the enabled extensions needed to be repaired. Other times only a few need to be fixed.

I cannot identify anything that might be causing the problem.

I would reinstall Brave but I have bookmarks saved. I assume that they will be lost. . .

I am also having issues with Brave not opening properly which I noted in an earlier post.

Brave V1.35.104
Big Sur 11.6.4

1 Like

When you say extensions need to be repaired, do you mean they crashed and need to be re-enabled? Or something else?

You can export your bookmarks as an html file (drop-down menu in the upper right corner of brave://bookmarks/) and then import them again after re-installing if you want to try that.

Brave not opening properly could be the result of Brave not having closed down properly or fully. And one of the things that prevents (or slows) Brave shutting down, can be extensions. Could you check whether Brave also does not open properly when extensions are disabled?
Also, check brave://settings/system to see that Brave does not continue running background apps.

I usually realize that there is a problem when the 1Password extension isn’t working. When I go to manage extensions, I see multiple extensions disabled with the Repair button showing.

Exporting the bookmarks is something I hadn’t thought of. . .

One of the strange things happening on my system is apps opening at boot even though they are not included in the Login Items in System preferences. Brave is usually one of the problem apps.

I just checked Settings/System and the only things showing are Hardware Acceleration (disabled) and Proxy Settings. I assume that something else would be there if a background app is running.

Thanks much for the ideas. I will try opening Brave with extensions disabled. It’s a shame that there isn’t a way to disable all of them at once vs. individually.

@MrRetro ,

Re “apps opening at boot even though they are not included in the Login items in System preferences”

You might test, by making a change in the Brave Browser > Settings at “Continue where you left off” – disabling that, and instead, using “about:blank”

First, close all Brave Browser windows, and then Quit Brave Browser. Then start Brave Browser and in a New Window, go to

brave://settings/?search=Continue+where+you+left+off

And adjust the settings to (about:blank) as shown;

Next, clear whatever caches, cookies, history, and site data you can (while keeping what you believe you must):

brave://settings/clearBrowserData

Quit everything and Restart your Mac.

Many thanks for the suggestion. I have completed the procedure and I will report back after I have had time to see if it works.

I’m still needing to repair multiple extensions after Brave opens. My next step will be doing a clean reinstall of Brave and the extensions. (As well as this configuration, of course. . .)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.