Browser Crash when moving tab to top of screen

Description of the issue:

With the browser open, when you drag a tab to the top of the screen/monitor the browser will crash.

How can this issue be reproduced?

  1. Open browser
  2. Have at least 2 tabs open
  3. Drag tab to the top of the screen/browser (try to move tab above the browser window)

Expected result:

The browser would/will not crash.

Brave Version( check About Brave):


Additional Information:

-Happens when minimized or maximized.
-Happens with or without extensions.
-Issue doesn’t happen on Linux

@arch_linux Can you get crash report? Would help if you can. Go to brave://crashes and make sure it’s uploaded, then provide the Crash Report ID.

Also, have you tried any of the basic troubleshooting steps yet? These are just some of the random little things that somehow seems to have impacts on a lot of issues people have within the browser. So tends to be good to rule them out, even if unlikely to play a part.

Such as:

  • Turning off Enable hardware acceleration when available at brave://settings/system

  • Opening/testing in Private Window instead of normal.

  • Creating a new profile and using it, without adjusting settings or adding extensions

  • Checking if this also happens in Chrome?

  • Checking if this issue also happens on Brave Beta or Brave Nightly?

Does this happen any time? Easily able to be replicated? Also, does it happen regardless of the type of content on the tabs?

Oh yeah, and which version of Windows? Is it 7, 8, 10, 11, or what?

Crash Report #'s




1.) It does happen every time
2. It does not matter what the content of the tabs are
3. I’m running windows 10
4. It happened with hardware acceleration enabled and disabled
5. I tried it on a separate machine and was able to reproduce it 100% of the time running windows 10
6. It does happen in private window as well
7. I’m able to reproduce this 100% of the time

Interesting. I would try to test but only have one machine, which is running Windows 11 Pro (where issue doesn’t seem to replicate) I’m tagging @Mattches in on this and hoping he’ll be able to investigate this week and offer a solution.

Thank you for reporting — I’m unable to reproduce this issue on my Win10 machine but I’ve forwarded the crash report IDs you provided to our devs for review.

Hope to have more information for you soon.

Apologies — can you please go to brave://crashes and actually upload the crash reports to us (there should be a Send or Send now option on that page under each crash)?

1 Like

@arch_linux If you don’t have a Send button, you may need to check brave://settings/privacy and make sure you have Automatically send diagnostic reports enabled. Without that, it won’t let you upload to them.

Btw, the crash report #s you provided, they said something like Crash Context instead of Uploaded Crash Report ID, right?

@Saoiray — to clarify, having Automatically send diagnostic reports enabled will send the crash reports to us without having to press any Send now buttons at all. Having it disabled simply means that you need to manually press Send now in order for us to receive the crash report. So you can still upload crash reports whether or not that setting is enabled or disabled, you just might have to do it manually.

@Mattches unfortunately, that’s not true. For example, I just went to brave://crashes and here is what I see:

And yes, I have settings on to automatically submit reports.

It’s been like that for a while. If not intended, may need to add it as a bug report or whatever. But you can see that I had one even from May 9, but it’s showing that it hasn’t sent. But now that I’m looking, I’ll hit the Send Now on both.

Hit Send Now and restarted the browser. Only one uploaded.

Photos 5_16_2023 12_52_49

Going to restart once more, then hopefully both will be there.


And yep, after restarting once more, there we go:

Photos 5_16_2023 12_54_21

But key idea: I had to hit Send Now for it to send the reports…

Also know we have had people, such as at Brave crashes when search bar is clicked, round two and Crashing like a hell on OOS, where they did not have Automatically send diagnostic reports enabled and it didn’t give them a Send Now option. It only enabled the abilty to Send Now if you have Automatically send diagnostic reports turned on.

Have seen this behavior regardless of which OS as helping here on Community. So essentially only sends crash reports if you tell it to automatically send diagnostic reports. But then those reports don’t automatically upload. Instead Users have to go in and submit them.

Oh, and @Mattches, it’s been like this for years. Hence why I figured it was “as intended.” Thought I mentioned to someone at one point that the phrasing should be changed or it should actually automatically submit. But if I did, it’s been a while and I forget who. But have “proof” of sorts where I’ve been having to give these instructions to people since at least July of last year. Since last update browser crashes - #8 by Saoiray

I’ll look into the expected behavior, thanks.

1 Like

Sounds good. I mean, it would be awesome if it works like you were saying it should. There’s obviously a lot of information that the developers haven’t been getting because of how this currently works. If they can get it corrected, it would help on QA.

Anyway, @arch_linux sorry to flood in so much on your topic here. If you didn’t get in touch with Mattches through DM or so, would help if you can make sure your report has been submitted and share that Crash Report ID when you can, assuming that Mattches was saying you submitted something else instead.

Sorry for the extended delay on the reply; I was on a trip. I did some further experimentation. When I went into the brave://flags settings I narrowed down the issue to it being the (Tab Scrolling with Dragging) setting and set it to default as it was set to enabled. When I set it to default I no longer have the crash issue. Thank you all for the help.

1 Like

Glad to hear it seems resolved, @arch_linux. I tried replicating just in case it was something we could submit a bug report on, but seems even with me enabling the flags for it, didn’t crash. It’s something that I’ll keep in mind though, just in case anyone else reports similar issue in the future.

For now, I’m going to mark your last reply as the Solution. Do advise if end up experiencing issue again and hope you won’t hesitate to post a new topic if you have any other type of problems.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.