Brave crashes when search bar is clicked, round two

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Description of the issue:

How can this issue be reproduced?

1.Open Brave, search for anything
2.Open a search result, click back to edit search
3. attempt to edit search query. Brave will crash.

Expected result:
Brave won’t crash
Brave Version( check About Brave):
Mobile Device details
Kyocera Duraforce Pro 2
Additional Information:
This issue was so bad that I switched to Firefox for the last 6 months. I missed brave, so i came back to try again. I can not believe this issue still persists. Initially this happened in brave and chrome. I no longer see this result in chrome. The first time around bitwarden was blamed, and i accepted that as it happened in several chromium browsers. Now it seems brave is the only browser not to fix it.

@121wfo Phooey, was hoping had resolved and that’s why you hadn’t been reappearing. Can you do a favor and try to get some of the crash report IDs together? I’m assuming you remember how, but will mention brave://crashes just in case.

Once you get that provided, I’ll try to see if we can get the devs to look at it again. But that aside, let me also ask:

  • Which OS are you running? I know you labeled for Android, but which version of Android?

  • Is this happening on the browser’s search/url bar or on search bars on websites?

  • Does it crash every time you tap on it or is it intermittent?

  • Random question for my own curiosity, does anything change if you go to SettingsAppearanceEnable bottom toolbar and you change it to the opposite setting of what you’re using?

@Saoiray I have switched browser as it was quite unbearable. But I can reinstall and test the toolbar position and crash reports this afternoon. I am running Android 10 on this device, but it also happens on my Samsung tablet running the current OS. This happened in the actual search/url bar of the actual search engine. It will only do it after you have clicked a result and gone back to edit the search query, or search for something different altogether. This happened 99% of the time. It’s like it causes a panic when the keyboard is called. Then brave closes.

Other odd thing to check then. If you change the default keyboard, will it happen? Also, which keyboard are you using?

It may be grasping at straws here but I’m the type to try any possibility regardless how slim. There have been times I’ve gotten lucky. I just know @Serg was speaking with you on this before and you had crash logs on it back then, with the last thing said was him going to look at what they could do and to check upstream. So hoping we can all get a closer look and test some things out to determine what’s going on.

@Saoiray Yeah my first thought when this first started was to blame the keyboard, so I tried several with the same result. I use Gboard.

@Saoiray Here is the crash… f2a38cf37418

It does it with toolbar on the top or bottom.

Part of your ID looks to be missing. That intentional, is it how the crash report ID showed, or what’s up? Crash report ID are usually long, such as: 590b0900-d60f-7509-0000-000000000000 (which was yours from before)

I know I tagged Serg earlier. He’s one of the developers for Android. I’m going to go ahead and tag two of the Support as well, which is @Mattches and @SaltyBanana in hopes that one of them will be able to help with that after they get in. Just hoping if was a mistake on that Crash Report ID, you can edit to have it included before they see it that way nothing delaying them from being able to investigate and try to resolve for you.

Got the same issue but it is due to keyboard in my case. I have install keyboard app in phone and use that keyboard for default it is lie stylish one and it cause trouble so i go back to google keyboard i got no error no crash. I recommend change the keyboard app.

@Saoiray that’s how they show up. Several of them!

@Saoiray Maybe because I’m not logged in?

There’s nothing to log in on it. Can you do a favor and share a screenshot of it here in a bit? I’m wondering if maybe it’s not uploaded or something? I mean, it’s possible format changed or something, but good to know. And if it is different than it’s supposed to be, it might help paint another picture for Support.

@121wfo Sorry, little addendum/correction to prior comment. I was just digging through posts to try to find a photo of what to look for when I think I realized what’s going on. What you have are ones that didn’t upload yet. So it shows the context, like in the screenshot below:

Which had been an issue last year, but it got fixed.

What it should be like is like you see below:

Normally shows Send Now if it can be sent. If it’s grayed out like in that screenshot, it just means have to exit Brave and reopen, usually will be sent. Then for those that went through, it’s like the bottom two where you have both crash context and crash ID.

It won’t have an option to send if you don’t have diagnostic reports turned on. Not sure if yours is off, but you can check it by going to Brave’s SettingsBrave Shields & PrivacyAutomatically send diagnostic reports and making sure it is enabled. If it wasn’t and you toggle it on, you should be able to have the option to send in the report and get the crash report ID.

@Saoiray here you go… 980f0600-f270-ff09-0000-000000000000… One thing I’ve noticed is that when I use other chromium browsers, the keyboard opens nice and smoothe. Even the few times that it doesn’t crash brave, the keyboard opens super clunky. I just tested another keyboard again also. Same result.

1 Like

@Saoiray I have played around with this extensively. This is 100% because of autofill being set to something other than Google. Shortly after I said it wasn’t happening in Chrome, it started happening there too. I tried a bunch of chromium browsers, only one was ammune to this, Vivaldi. Not a clue why. Once I changed autofill back to Google instead of Bitwarden (I just put Bitwarden in accessibility). All browsers behaved normally. Maybe they key is finding out what is different in Vivaldi? But I’m good with this solution. I have no problem using Bitwarden in accessibility mode.

@121wfo glad to hear it. Actually looking back to what Serg talked to you on before, he mentioned it was happening in autofill and was going to reach out to Bitwarden. So I guess it kind of had been narrowed. I made the assumption it was known and issue was happening anyway.

In terms of it happening on other Chromium browsers, then that sounds like something that would have to be submitted to bugs on Chromium side. I’m too lazy to go looking right now to see if it’s already been mentioned, but you may want to check on it yourself. Most likely just has to be handled upstream. At the same time, you may want to share it with Bitwarden as well as they may need to make some changes on their end.

I’ll go ahead and mark this topic as solved then, as at least issue is identified and aware it’s either upstream issue or Bitwarden problem.

@Saoiray Yeah I see it’s been upstream at Google for some time with no resolution. I see multiple password managers being mentioned, not just Bitwarden. It had been mentioned to me before to try turning off Bitwarden autofill. Which I was not willing to do. And I forgot that Bitwarden could also use accessibility to call the vault, which I’m ok with. Thanks for your help with this!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.