External Links Not Opening - Brave As Default Browser

Problem:
When Brave is set as the default Browser on Windows 10 or iOS, and the browser is open, and a URL link is clicked in an external app, the link does not open and nothing happens.
Linux users report that when attempting to open links from external apps that Brave may crash, or they may get an error message:

Failed to execute child process “/usr/bin/brave-browser-stable” (Permission denied)

Expected behavior
Brave should open to the URL in the clicked link.

Solution / Work Around (at least in Windows 10)
1: In Brave’s settings, toggle “Close window when closing last tab”
2: Restart Brave. External Links should now open in Brave.
3: Toggle back “Close window when closing last tab”
4: Restart Brave. External Links should continue to open in Brave.

This worked for me and user blr. (Note: in older versions of Brave, the “Close window when closing last tab” feature was called “Don’t Close Window With Last Tab”, and toggling that also solved the bug as of brave version 1.38.111 Chromium: 101.0.4951.54 .)

Alternative Solutions

  1. Uninstall Brave
  2. Deleted the local content
  3. Reinstall Brave
    This solution worked for DanG (link under Bug History).

Details from my experience

  • Brave Version: Version 1.38.111 Chromium: 101.0.4951.54 (Official Build) (64-bit)
  • OS: Windows 10 Enterprise
  • External apps: Problem is Outlook and Joplin

Details observed in other posts, apparently reporting the same bug

Bug History
This bug has been reported on this forum at least 11 other times since 2019, on diverse platforms and Brave versions. And none of them were helped and only 2 found resolution. Reporting users and posts:

  • blr (Windows 10)
    https:// community .brave.com/t/external-links-no-longer-opening/393089
  • DanG (Windows 10 Home 64 bit)
    https:// community .brave.com/t/brave-will-not-open-hyperlinks-clicked-in-other-applications/184061
  • mightyfrot (iOS 14.8.1)
    https:// community .brave.com/t/brave-won-t-load-links-from-any-apps/300957
  • MCabZ (windows 10)
    https:// community .brave.com/t/external-urls-fail-to-open-in-brave-as-default-browser/213575
  • leonardosgz (iOS 14.3)
    https:// community .brave.com/t/external-links-not-opening-on-brave-ios/189739
  • Javgarag (Windows 10)
    https:// community .brave.com/t/when-trying-to-open-a-link-from-an-external-program-nothing-will-happen/70008
  • Mikey705 (iOS 14.8.1)
    https:// community .brave.com/t/opening-links-from-external-apps-in-brave-ios-app/303402
  • svda (elementary OS 5.0 Juno, experiences error messages)
    https:// community .brave.com/t/external-pdf-unable-to-open-external-link-elementary-os-5-0-juno/73195
  • _tangles (Ubuntu, experiences crashes)
    https:// community .brave.com/t/brave-crashes-when-opening-links-provided-externally-ubuntu/146182
  • Vlama (Ubuntu 18.04.2, experiences crashes)
    https:// community .brave.com/t/brave-crashes-when-opening-a-link-from-external-application/54314
  • kranthireddy
    https:// community .brave.com/t/redirecting-links-from-external-app-or-site-crashes-brave/186767

(Due to the 4 hyperlink limit on posts I’m inserting spaces in the URLs)

1 Like

Hello there @particleman137 please accept my apologies for this issue. Could you please update Brave to its latest version to see if the issue with the external links is solved?

As of this day, the latest Brave version is Version 1.45.133 Chromium: 107.0.5304.141 (Official Build) (64-bit)

Let me know if that works.

Hello @Kevin_cc,
As mentioned in my post, the listed solution worked for me, and I don’t have a procedure for reproducing the problem. I’ve already spent a bit too much work time documenting the problem and it’s kluge solution.
Best wishes

1 Like

Thanks for the response and accept my apologies as I misread your post. If you have any other comments or concerns you can let us know by creating a community post.

Regards.