Brave Version 1.14.84 Chromium: 85.0.4183.121 Win10 2004 HW Acceleration Problem

Since upgraded to version above with Windows 10 v2004 and I have hardware acceleration on, Brave gets all garbled as shown in the image.


I have an Asus K450JN laptop with Geforce 840M and Intel HM4600.

If I turn off hardware acceleration, the problem goes away.

Any help on solving this? All drivers are at the latest versions.

Brave Version 1.14.84 Chromium: 85.0.4183.121

Windows 10 v2004 build 19041.508
Windows feature Experience Pack 120.2212.31.0
Video Drivers:![geforce840m-pixelation-win10v2004|690x317]
|Name|Intel® HD Graphics 4600|
|Adapter Description|Intel® HD Graphics 4600|
|Installed Drivers|igdumdim64.dll,igd10iumd64.dll,igd10iumd64.dll,igd12umd64.dll|
|Driver Version|20.19.15.5144|
Driver C:\WINDOWS\SYSTEM32\DRIVERS\IGDKMD64.SYS (20.19.15.5144, 7,61 MB (7 984 480 bytes), 10/08/2020 15:52)
|Name|NVIDIA GeForce 840M|
|PNP Device ID|PCI\VEN_10DE&DEV_1341&SUBSYS_22AA1043&REV_A2\4&F2029B0&2&0008|
|Adapter Type|GeForce 840M, NVIDIA compatible|
|Adapter Description|NVIDIA GeForce 840M|
|Driver Version|27.21.14.5638|
|Driver|C:\WINDOWS\SYSTEM32\DRIVERSTORE\FILEREPOSITORY\NVAMI.INF_AMD64_8592088B0B875D85\NVLDDMKM.SYS (27.21.14.5638, 30,95 MB (32 457 456 bytes), 20/09/2020 07:11)|

to get to know which driver causing that try to make brave use each card
so try with the intel one
then try with invidia one

hope at least one of them work with the HW accerleration

and have a nice day

Keep it off, it should be fine!

Looks like either your Integrated Graphics is causing the problem or the Dedicated graphics is having issue!

In my case I had a problem with my Dedicated Graphics RTX so I turned off the HW and it’s working fine now, so if you don’t find any other solution then keep off the HW option.

1 Like