Brave update reset everything, lost BAT, settings, extensions and bookmarks

Description of the issue:
Updated Brave to Version 0.66.99 Chromium: 75.0.3770.100 (Official Build) (64-bit) (thank you Ubuntu auto updates :expressionless:), the system restarted ran brave and went “wait, where’s my bookmarks” followed by “wait where’s EVERYTHING”.

I live my life in misery now. Currently rebuilding my life piece by piece. Thankfully, I had my bookmarks recovery key so life is starting to get back on track. BAT is hopelessly lost, extensions shall be reinstalled, desktop shortcuts cease to work and shall be removed and recovered.

Breakdown of things lost -

  • Bookmarks
  • Extensions
  • BAT Wallet
  • Preferences
  • Peace of mind

Steps to Reproduce:
1.Upgrade Brave
2.Lose Everything

Actual Result (gifs and screenshots are welcome!):
As you can see, I’ve lost everything.

Expected result:
Not lose everything.

Reproduces how often:
This is happening for a third time, but doesn’t happen on every update. It seems to be a Linux problem because updating brave on Windows works perfectly fine even on Beta.
When it happened the second time, I removed brave, reinstalled and suddenly somehow everything was back. Tried the same thing this time but didn’t work.

Operating System and Brave Version(See the About Brave page in the main menu):
Ubuntu 18.04.2 LTS
Version 0.66.99 Chromium: 75.0.3770.100 (Official Build) (64-bit)

Additional Information:
Can I get my BAT back? They were BATs from Ads so there’s no receipts but idk, ideas?

Can you tell me steps that you use to install Brave? Did you follow steps mentioned here ?

cc @Mattches @sriram for additional assistance here

To clarify, the second time was around 3 weeks back so it must’ve been a different version. But I removed it using sudo apt remove brave-browser, then re-downloaded the .deb package and installed it using sudo apt install -f package.deb and it somehow magically worked.

Tried the same thing this time but it didn’t work.

Edit -
My memory could be rusty but I remember downloading a package from to install it. I can’t find the same anymore though. Either way, I’m pretty sure it wasn’t a beta or nightly.

And I’m not using the nightly channel, I’m using (supposed to be stable :stuck_out_tongue:) release channel.

Update - It’s back again.

I restarted the computer around 2-3 times due to some issues with chrome remote desktop messing up my sound.

Fixed it using sudo apt remove chrome-remote-desktop, restarted the system. Now all my settings, bookmarks, everything is back.

Witchcraft, I say.

@Mattches @sriram if you need any help running any tests specific to my environment, I’d be happy to help.

1 Like

Well that is quite a roller coaster ride you had. Quick question though did you happen to remove your profile when you removed the installation? Also could you check how many Brave-Browser folders you have under ~/.config/BraveSoftware/ ? My guess is your original profile was still there but when you install manually via .deb file it must have created a different profile folder

This topic was automatically closed after 30 days. New replies are no longer allowed.

I only have one ~/.config/BraveSoftware/Brave-Browser folder. Also, didn’t delete the user, it just disappeared on restart after the update.
I realized that it always fixes as soon as I remove chrome-remote-desktop . My best guess is chrome-remote-desktop is somehow misleading Brave (and possibly other apps) from pointing to the correct config directory. I don’t know how to test that hypothesis though.

This was a problem on Ubuntu 18.04.2 with Brave . I had chrome-remote-desktop installed, as well as the remote desktop extension installed
I followed this guide to debug an issue about remote-desktop showing an empty, black screen.

While remote-desktop was installed, upon a system restart after an update to Brave, it suddenly reset, akin to a fresh install or a new user being created.
chrome-remote-desktop was also causing issues with my audio setup, changing my sound device from the regular pulseaudio to Unix FIFO sink, and any audio applications including websites on brave refused to play any audio and kept on crashing.
I had to get rid of chrome-remote-desktop, and suddenly after the next restart, brave was back to it’s original state.

@sriram I refuse to install chrome-remote-desktop as it messes with the whole system, but for science, I can.

@arpit9295 Thanks for the info. I will try replicating the setup and see what is going on. Might need some time to test this.

That is totally fine. No need to mess up your daily driver machine for this. I can try setting it up on a VM and see whats going on.

i have everthing correct but today everything and everything got deleted
i recovered my passwords (not all) from a password export and then imported it back but everything is lost and not all my passwords are back :((((

This is the second time this has happened to me. First time auto-contribute was erroneously turned on. I sent the support e-mail as instructed but never received a reply (about 50 BAT still missing), most recently I think I had 6 or 8 BAT and it was gone, no sign of auto-contribute and restoring did not return BAT. I do have DEV and the regular build installed though. Perhaps need to remove one? Started using DEV back in at least 2019, can’t recall when. Version 1.11.104 Chromium: 84.0.4147.105 (Official Build) (64-bit)