Brave tabs opening too slow to enter a link


For the last few days, Brave’s tabs are opening too slow, and sometimes it crashes and I have to restart again. I also have to click on the ‘sign’ - reload the page many times, and it takes a few minutes for each tab to respond.

I use my computer and haven’t changed any settings for this to happen, including the ones on my Brave.

Any suggestions, please?



Hello @lmz, thank you for bringing this to our attention. What kind of device and OS are you using? Have you tried deleting cookies and cache recently? Are you using extensions? Does the same happen in a private window? Let us know if that helps.


Thanks for your prompt reply.

It began a few days ago and have not changed anything in my computer (Windows 10).

I do a complete cleaning of cookies and cache every single night when done with my computer using CCleaner, etc. I remove prefetch and temp files, etc. as well (suggested by my Norton Antivirus support).

Before these few days, everything was fine. I open a tab and can watch paint dry, that’s how I can explain it. Most of the time the tab crashes as shown on my screenshots.

Please, let me know what options I should take as far as this Brave browser slowdown and crashes.

Thank you,

What version of Brave are you on? you can check in settings>About Brave

Hello @lmz, I am following up this case. Is this still an issue for you?


This issue was fixed by Brave… I no longer have this issue.

Thank you for all your prompt help.

1 Like

You’ re welcome! Glad to hear that. Regards.

Well, it has come back, freezing tabs, unresponsive tabs/links…

Test in private window mode?

Hello again @lmz, can you try disabling the following to see if that resolves the issue:
You’ll find this under: Settings --> System --> Hardware Acceleration

Hello @lmz

Is this still an issue for you?

Be waiting for your response!

Lately, Brave browser keeps messing up with the internet. I use my iPad and have no issues, therefore it’s Brave. I keep reporting the broken links but keep having the same result of trying to open a tab with a link and it stays in limbo for a very long time… very frustrating!

I clean my cookies, etc. through CCleaner every single day and through run I also clean the prefetch and %temp% files as it was suggested by my Norton anti-virus service a while back… therefore, it’s not a lost cookie somewhere…

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.