Brave Suggestions cover up text fields

Description of the issue:

Brave Suggestions drop down starts from the text box itself and covers the text box, and it is literally impossible to see what I am typing. Often, the suggestions are random **** from other unrelated sites, so is not remotely relevant.

How can this issue be reproduced?

  1. Open a website
  2. Click on (touch?) a text field
  3. Marvel in the glorious list of 10 random recommendations filling up the whole damn screen. Even if there are only 2 or 3, it still starts from the text box itself.
  4. Touch another part of the screen, click the back button, or swipe or whatever hoping that the recommendations go away
  5. See your keyboard disappear
  6. Repeat step 2 ad nauseum till either you manage to get the recommendations out of the way, or use another browser, or just manually delete every recommendation. Btw, the recommendation list will repopulate with more recommendations for quite a long while. Good luck.
  7. ???
    8.Profit?

Expected result:

The recommendations don’t cover the text fields

Brave Version( check About Brave):

1.37.110

Mobile Device details

Moto G10 Power, Android 11

Additional Information:

Yes Me too

Please keep this open.

We have a solution for this Sir…
Pls open settings and click on appearence and then turn of (Show autocoplete in address bar)
This shld help you…
Love from India…

Hi.

The solution to having a UI issue that makes a nice feature unusable is not to just turn it off, maybe the UI can be improved on instead?