Brave stopped working in Windows 10

Description of the issue:

I have installed Brave about three months ago works great! Two weeks ago I started getting notifications that Brave can’t update and to reinstall. I ignored them until 12/22/2019, I clicked on the update and reinstall button. Following download (download complete) I reinstalled Brave (Install Complete). Clicked on the Brave icon and I got a white screen " Aw, SNAP! Something went wrong while displaying this webpage."
Nothing works, I can’t reload, I can’t get to help, nothing. I have tried uninstalling Brave (twice) and downloading the newest version as of 12/24/2019 (twice). No change.

Brave Version( check About Brave):
Can’t tell. Whatever version was available as of 12/24/2019
Additional Information:
Windows 10 Home
Version 1903
Installed 8/6/2019
OS build 18362.418

PCMATIC Super Shield Version

Everything was working great until I did the update…

Thanks in advance for your help.


I’m having the same problem, and it started yesterday as well. Upgraded to Win 10 Pro and left my other settings/apps (in other words, not a complete clean install), tried running Brave and it gave me the “aw snap” page. Can’t do anything with it–settings page, “about:config” page won’t load (sits and spins until closed), Uninstalled & reinstalled several times, still gives me the same errors.

I had two extensions loaded previously, Privacy Badger and HTTPS Everywhere. When I initially tried to run Brave, I got two popups saying those two extensions had crashed, click here to reload; that was an infinite loop.

Finally cleaned all off the hard drive (ALL brave files searched for and deleted), ran CCleaner several times to get everything out of the registry, and tried installing again–same effect, “aw snap” page and can’t do anything with it.

In addition, Chrome locked up the same way–“aw snap” page for everything. Not sure if that’s related, but that problem started today as well.

Windows info:
Edition: Windows 10 Pro
Version: 1909
Installed on: 12/24/2019
OS Build: 18363.535

I have four other machines running Win 10 Pro and Brave, two of them upgraded to Win 10 in the last week. This is the only machine showing this problem.


In my case, because of the update (vs clean install), I had a virus protection program installed under Win 7 that doesn’t work with Win 10 but stayed resident. For some reason it was blocking Chrome and Brave access to the internet. I uninstalled the software (Symantec Endpoint Protection), and everything now works just fine.

I’d check to see if you installed any virus protection or other privacy software that conflicts with Win 10.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.